Current time: 04-23-2014, 08:51 PM Hello There, Guest! (LoginRegister)

Post Reply 
change max upload size problem
01-03-2007, 04:52 AM
Post: #31
change max upload size problem
Quote:If you can't accomplish those steps, you should not be modifying php.ini at all.
I think you are right. I don't want to appear disrespectful to the original poster, but given the problems he has had thus far following the instructions in the wiki article, despite the excellent help that you have provided, I don't think he should even be attempting this.

Mark

--
Save $50 on DreamHost plans using PRICESLASH promo code (Click for DreamHost promo code details)
Visit this user's website Find all posts by this user
Quote this message in a reply
01-03-2007, 04:56 AM
Post: #32
change max upload size problem
i followed these steps to do. I already be confused for the php-update.sh. I changed the [working directory] to my website directory. but i *execute* the script, it come out can't execute and come out a list of errors. This causes me more messy for it.
Find all posts by this user
Quote this message in a reply
01-03-2007, 09:11 PM
Post: #33
change max upload size problem
Can't open 100M/: No such file or directory.
./php-update.sh: line 11: unexpected EOF while looking for matching `''
./php-update.sh: line 12: syntax error: unexpected end of file

while i execute the script, the results as above,

the code in php-update.sh script is below:
#!/bin/sh
CGIFILE="$HOME/cgi-bin/php.cgi"
INIFILE="$HOME/cgi-bin/php.ini"
rsync -a /dh/cgi-system/php5.cgi "$CGIFILE"
cp /etc/php5/cgi/php.ini "$INIFILE"

perl -p -i -e '
s/.*post_max_size.*/post_max_size = 100M/;
s/.*upload_max_filesize.*/upload_max_filesize = 300M/;
' "$INIFILE""$INIFILE" 100M/;
' "$INIFILE""$INIFILE"

how it comes to the result?
i mistake any step for the script?
Find all posts by this user
Quote this message in a reply
01-03-2007, 09:33 PM
Post: #34
change max upload size problem
Quote:i mistake any step for the script?
The script *should* look like this.

#!/bin/sh
CGIFILE="$HOME/yourdomain.tld/cgi-bin/php.cgi"
INIFILE="$HOME/yourdomain.tld/cgi-bin/php.ini"
rsync -a /dh/cgi-system/php5.cgi "$CGIFILE"
cp /etc/php5/cgi/php.ini "$INIFILE"

perl -p -i -e '
s/.*post_max_size.*/post_max_size = 100M/;
s/.*upload_max_filesize.*/upload_max_filesize = 100M/;
' "$INIFILE"


Replace the yourdomain.tld with the name of the web directory for your domain, usually this will be named the same as your domain, and be sure that you have created a cgi-bin directory within your domains web directory.

As stated by rlparker a number of times, you really must follow the instructions in the wiki article precisely, read everything in there and DO NOT skip any steps. If you still can not get it to work, I would suggest finding someone with more experience with these kinds of things to do it for you.

Mark

--
Save $50 on DreamHost plans using PRICESLASH promo code (Click for DreamHost promo code details)
Visit this user's website Find all posts by this user
Quote this message in a reply
01-03-2007, 09:44 PM
Post: #35
change max upload size problem
if my domain name is abc.com, then what i should type?
Find all posts by this user
Quote this message in a reply
01-03-2007, 09:54 PM
Post: #36
change max upload size problem
Quote:if my domain name is abc.com, then what i should type?
If your domain is abc.com and the web directory for that domain is called abc.com (it probably is), then the two lines in the script above would look like this;

CGIFILE="$HOME/abc.com/cgi-bin/php.cgi"
INIFILE="$HOME/abc.com/cgi-bin/php.ini"


and, as I said in my previous post, make sure you have already created a cgi-bin directory within your domains web directory (ie: abc.com/cgi-bin/) before running the script. You can use a shell command something like the one below to create this directory.

mkdir ~/abc.com/cgi-bin/

This is all explained in the wiki article. Confused

Mark

--
Save $50 on DreamHost plans using PRICESLASH promo code (Click for DreamHost promo code details)
Visit this user's website Find all posts by this user
Quote this message in a reply
01-03-2007, 09:55 PM
Post: #37
change max upload size problem
yes. i already changed to shell user. i execute the script using putty.
Find all posts by this user
Quote this message in a reply
01-03-2007, 10:04 PM
Post: #38
change max upload size problem
this step already be done. but my php script list out the max upload size is 7M, post size is 8M.
how to update it?
Find all posts by this user
Quote this message in a reply
01-03-2007, 10:27 PM
Post: #39
change max upload size problem
after i finished upated the php script, but my website can't browse, it come out this problem as below,

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@abc.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

how to solve this?
Find all posts by this user
Quote this message in a reply
01-03-2007, 10:33 PM
Post: #40
change max upload size problem
Quote:Internal Server Error
It sounds like you messed up the .htaccess file.

Firstly, do you now have a directory within the web directory for the domain called cgi-bin (example: abc.com/cgi-bin/) ?

Does this directory contains 2 files, php.cgi and php.ini ?

Now confirm that you have added the following lines to your .htaccess file.

Options +ExecCGI
AddHandler php-cgi .php
Action php-cgi /cgi-bin/php.cgi


Mark

--
Save $50 on DreamHost plans using PRICESLASH promo code (Click for DreamHost promo code details)
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: