Current time: 04-23-2014, 12:33 PM Hello There, Guest! (LoginRegister)

Post Reply 
MT Install
07-28-2003, 05:56 AM
Post: #21
MT Install
i made it a sub directory. it's actually http://mike.teamvf.com

the folder is in my username's root folder

tried switching back to ./db for datasource and still a 500
Quote this message in a reply
07-28-2003, 07:22 AM
Post: #22
MT Install
How about the permissions for the actual mtdirectory ? What are they (and FTR, what should they be)?

One sanity check I did was to actually log in to MySQL directly, using the Dreamhost tip sheet for this--and the first time I couldn't, because I had a typo in the database user password.

I'm also not sure why your sql database has an extra level. It may not matter, but I don't know why you did name.name.domain.com instead of name.domain.com ...
Find all posts by this user
Quote this message in a reply
07-28-2003, 01:39 PM
Post: #23
MT Install
well the sql.mt.mydomain.com i just always kept it tied to the subdomain to make it easier for me to keep up with. always done it like that and never had any problems, but then again maybe just MT has a problem with it.

but the actual root folder that all the stuff is in is 777

did a connection to mysql dbase through ie and connected fine, double checked the pw in the cgi file and all the other info in the cfg file and all checks ok.
Quote this message in a reply
07-28-2003, 01:45 PM
Post: #24
MT Install
[Sun Jul 27 21:02:40 2003] [error] [client xxx.xxx.xxx.xxx] Premature end of script headers: /home/username/foldername/mt-load.cgi

is the error message in my error logs over and over again.
Quote this message in a reply
07-28-2003, 01:49 PM
Post: #25
MT Install
oh and this one too they post together at the exact same time:

[Sun Jul 27 21:03:07 2003] [error] [client xxx.xxx.xxx.xxx] Premature end of script headers: /home/username/foldername/mt-check.cgi

also had some about file was missing, but that was when i was checking stuff out trying diffrent things i think. it's in the right area now, just the scripts ain't doing something right.
Quote this message in a reply
07-28-2003, 02:05 PM
Post: #26
MT Install
That's a pretty generic error, and is almost definitely due to one of the following two things:

1) Permissions are incorrect
2) File has DOS carriage returns in it.

Try using dos2unix on the files and doublecheck your permissions.
Visit this user's website Find all posts by this user
Quote this message in a reply
07-28-2003, 02:14 PM
Post: #27
MT Install
which file? the mt.cfg? and what is dos2unix? is that a progam i use to log into dreamhost with? like telnet or a ftp client?
Quote this message in a reply
07-28-2003, 02:16 PM
Post: #28
MT Install
Not the config file; the scripts themselves.

You can run dos2unix from the command line (on the server); you'd need to make sure that shell access is enabled for that user, and then ssh or telnet in.

First, though, doublecheck the permissions on the scripts and the directories they're in... make sure that there aren't any group-writable directories.

Make sure that CGI access is enabled (in the web panel) and is set to run as the user that owns the scripts.
Visit this user's website Find all posts by this user
Quote this message in a reply
07-28-2003, 02:26 PM
Post: #29
MT Install
ok did a dos2unix *.cgi and went back to my root folder, it was 777 so changed it to 755 along with all the other directories that mt comes with and went though everything. it's installed finally. thanks man
Quote this message in a reply
07-28-2003, 02:28 PM
Post: #30
MT Install
one last thing? can the mt.cgi be renamed to index.cgi so not to have a meta refresh or anything? or is there a simple way i can mirror the mt.cgi w/o having to refresh and forward to it?
Quote this message in a reply
Post Reply 


Forum Jump: