Current time: 04-16-2014, 05:54 PM Hello There, Guest! (LoginRegister)

Debian issue on my home computer
10-25-2005, 08:25 PM
Post: #1
Debian issue on my home computer
I've got Debian Sarge, freshly installed on my computer. I used a net install CD and just installed the standard packages for a desktop system and a server. (I want it to have the functionality of a standard desktop, and a dev platform for websites and the like) Anyways, all was going well. I got into Debian, (gnome) and ran the package manager to make some changes.

Here's the stupid thing I did: while running gnome, I told the package manage to un-install gnome. KDE was already in there, and I added a few extra things in as well. After that went through I rebooted the computer so it would load up KDE... or not. The computer boots, and I'm promoted with a text login. I can type "startx" and get KDE, that all works just fine - but how do I get it to start x automatically when I boot up, and use the graphical login again?

I got this sigguestion on an other forum:
"use your favorite text editor to edit the inittab file int the /etc directory. edit as follows: change the 3 to a 5 in this line:

id:3:initdefault:

so it looks like this:

id:5:initdefault:

that should do it."

I tried that, but the situation is the same. I'm wondering if that is the proper variable to change, but the wrong number? It's possible that my computer is now trying to load ICEwm, as I think I saw that in a directory that went by just before I get the login prompt.

Any sigguestions are apprechated. I suppose I could do a re-install, but I'd rather not becuase I've just got a net install CD, and it takes a bit to download all the packages. Thanks!

-Matttail
Visit this user's website Find all posts by this user
10-25-2005, 09:44 PM
Post: #2
Debian issue on my home computer
Well if you uninstalled gnome... but not kde... i think that you wish a graphic login...
what about trying:
apt-get install xdm
(or kdm, or something... apt-cache search kdm )
this will get maybe return your graphic login.

also you had to make it run
/etc/init.d/kdm (or xdm or what you choose) start

Regards
Visit this user's website Find all posts by this user
10-26-2005, 05:57 PM
Post: #3
Debian issue on my home computer
I got it figured out. It was that I had uninstalled GDM when I removed Gnome. So I got that working by using the package manage to re-install. But then I realized that my screens wern't switching properly (ctrl+alt+F#) - I only had the boot screen and the one x was loaded into. When I switched the inittab setting back to the default that fixed it. Now all is well with the world!

Thanks for the help.

-Matttail
Visit this user's website Find all posts by this user


Forum Jump: