Current time: 07-12-2014, 01:08 PM Hello There, Guest! (LoginRegister)

Post Reply 
Subversion, netbeans not working
01-23-2012, 02:58 PM
Post: #1
Subversion, netbeans not working
Hello,

I am trying to setup a Subversion for my project.

I have setup the Subversion project through the Dreamhost panel (Goodies > Subversion) about a week ago. It says the project is created and ready to go. (I have "leave it alone" selected for the "add www" option in my configuration)

But nothing I do in Netbeans seems to work. I have bad experiences with Tortoise so I'd prefer to avoid it.

Netbeans asks for 3 things:
1) Repository URL
2) User
3) Password

I am sure I have the user / password correct, so I must be doing something wrong with the URL. So, these are the URLs I've tried:

1) http://www.vantagecp.com/Project
Result: org.tigris.subversion.javahl.ClientException: '/Project' path not found: 404 Not Found (http://www.vantagecp.com)

2) http://vantagecp.com/Project
Result: org.tigris.subversion.javahl.ClientException: Repository moved permanently to '/Project'; please relocate
OPTIONS request failed on '/Project'

3) http://vantagecp.com/
Result: org.tigris.subversion.javahl.ClientException: Repository moved permanently to '/'; please relocate
OPTIONS request failed on '/'

4) http://www.vantagecp.com/
Result: org.tigris.subversion.javahl.ClientException: Malformed XML

Netbeans gives an example url next to the URL box that says
"http://hostname/repository_path[@REV]"

I've worked on projects with SVNs before and I've never really had trouble, but I've never setup my own SVN so I'm a bit of a newbie.

Thanks in advance for your help.
Find all posts by this user
Quote this message in a reply
01-23-2012, 04:23 PM
Post: #2
RE: Subversion, netbeans not working
Quote:about a week ago

The password may have been changed. You didn't mention the security password issue, only that you set it up a week ago, so perhaps your password is not valid. Just a guess. http://www.dreamhoststatus.com/2012/01/2...ity-issue/
Find all posts by this user
Quote this message in a reply
01-23-2012, 05:05 PM
Post: #3
RE: Subversion, netbeans not working
(01-23-2012 02:58 PM)vantagecp Wrote:  I am sure I have the user / password correct, so I must be doing something wrong with the URL. So, these are the URLs I've tried:

I've switched to Git, so I don't remember clearly, but all the Subversion repos I've worked with have been accessed over svn+ssh:// or something like that. Have you tried svn:// rather than the http protocal?
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: