Current time: 04-23-2014, 12:34 PM Hello There, Guest! (LoginRegister)

Post Reply 
ownCloud on shared server
10-08-2011, 11:47 AM
Post: #1
ownCloud on shared server
Hi,

before anything, excuse me if this topic has been treated before, but i receive a kind-of-weird 0 hits on reply to my search. So there is some chance i did something wrong.

That being said, i'm trying to get ownCloud up and running on a shared server.

What i've got until now.

* Server running PHP 5.3 FastCGI.
* ownCloud 2 beta 3 installed and web interface working properly. Users can be created, files may be uploaded. Everything /seems/ to be smoothly running.
* I'm *unable* to connect neither using Nautilus built-in support for webdav nor via Finder built-in support for webdav. The former gives a "time-out server not there connection broken" mixed and long error message. The latter says my user/pass is incorrect.

Any ideas?


Thanks :)
Find all posts by this user
Quote this message in a reply
10-08-2011, 07:31 PM (This post was last modified: 10-08-2011 07:32 PM by Ryo-ohki.)
Post: #2
RE: ownCloud on shared server
Not to seem stupid or anything but did you actually set up webdav from the dh control panel on your domain and add users/passwords?

http://www.marciesgifts.com
PM for manual CMS(drupal,joomla,etc)/Blog(WP,MT,etc
)/forum(phpbb,smf,etc) install/transfer $75.
$25 Off w/promo code SPRINKLES
Visit this user's website Find all posts by this user
Quote this message in a reply
10-09-2011, 04:21 AM (This post was last modified: 10-09-2011 04:28 AM by versvs.)
Post: #3
RE: ownCloud on shared server
Hi Ryo-ohki, thanks for your reply.

Regarding your question,

I tried both things. The first was trying to access the webdav directory through the .php script provided by ownCloud (it's supposed to keep you from managing all the webdav stuff). This attempt gave me the kind of errors I mentioned above.

I also tested the other way. In this case, trying to access the ./data directory inside owncloud gives a 403 error and no dialog box to enter user/pass. Trying to access via finder, an error message urges me to verify the IP address or contact my sysadmin Smile

Ok, i'll keep trying different things today, and i come to something useful will put it here for it may be useful to someone in the future Smile

*Ninja edit to ADD*
Trying to access the php script directly through a web browser prompts my with a log-in dialog, to no success. It is not sending the auth info and so it gets back to the initial point (log-ind dialog) in a loop that ends when you get a bit bored and press CANCEL. Then, you receive an XML file:


<d:error xmlnsBig Grin="DAV:" xmlnsConfused="http://sabredav.org/ns">
<s:exception>Sabre_DAV_Exception_NotAuthenticated</s:exception>
<s:message>No basic authentication headers were found</s:message>
<s:sabredav-version>1.5.3</s:sabredav-version>
</d:error>


Any ideas?
Find all posts by this user
Quote this message in a reply
10-09-2011, 07:16 AM
Post: #4
RE: ownCloud on shared server
Do you 'have' to use webdav? I'm pretty sure you have to either not use webdav and use the web interface OR use webdav and only be able to access it that way and nothing else.

http://www.marciesgifts.com
PM for manual CMS(drupal,joomla,etc)/Blog(WP,MT,etc
)/forum(phpbb,smf,etc) install/transfer $75.
$25 Off w/promo code SPRINKLES
Visit this user's website Find all posts by this user
Quote this message in a reply
10-09-2011, 07:50 AM
Post: #5
RE: ownCloud on shared server
Yup, that's the alternative. Using owncloud seemed a good idea, as it provides the ability of syncing many things while having them accesible via webinterface for eventual access (i.e. not your usual computer).

Thanks again!
Find all posts by this user
Quote this message in a reply
10-11-2011, 03:13 PM
Post: #6
RE: ownCloud on shared server
Hi,

I have the very same problem as described above.
Now, I've tried to enabe WebDAV on my data directory of the ownCloud install, but it didn't change anything ...

Anybody got any ideas how to fix this? I think ownCloud is just great, I only really want webDAV to work ...

Has it got anything to do with the htaccess files?

THANKS
hein
Find all posts by this user
Quote this message in a reply
10-14-2011, 03:48 PM
Post: #7
RE: ownCloud on shared server
I've the same problem ...
It seems to be related to something like this http://code.google.com/p/sabredav/issues...l?id=25#c0

so pbm with dreamhost implementation... if someone find a solution ....
Find all posts by this user
Quote this message in a reply
10-17-2011, 10:01 AM
Post: #8
RE: ownCloud on shared server
I've found a solution .... change your htaccess to include :

Code:
<IfModule mod_rewrite.c>
  RewriteEngine on
  RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]
</IfModule>
Find all posts by this user
Quote this message in a reply
12-02-2011, 09:09 AM
Post: #9
RE: ownCloud on shared server
Sorry to hijack this thread, but it's the only one I could find re: ownCloud.

I'm attempting to install ownCloud on my DH shared server, and I'm running into this error after uploading the files to my site:

PHP module zip not installed.
Please ask your server administrator to install the module.

Any idea how to fix this?
Find all posts by this user
Quote this message in a reply
12-20-2011, 01:03 AM
Post: #10
RE: ownCloud on shared server
And I hate to hijack an already hijacked thread, but how can I change the max upload limit? Every time I try to change it using php.ini, I then update the .htaccess file with:
Options +ExecCGI
AddHandler php5-cgi .php
Action php-cgi /cgi-bin/php-wrapper.fcgi
Action php5-cgi /cgi-bin/php-wrapper.fcgi

This is per the DH wiki at: http://wiki.dreamhost.com/Php.ini#Custom...le_domains

Alas, no joy. I get an error from OwnCloud. Any thoughts?

THANK YOU!
Ryan
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: