"Your PHP installation appears to be missing the MySQL extension which is required by

wordpress

#1

…“Your PHP installation appears to be missing the MySQL extension which is required by WordPress.”

My WordPress site is down (for more than 24 hours now) and having trouble fixing it - from spending hours already trying to uncomment extensions in php.ini file but nothing is working. Nothing was done to the site at all, so this came after the Ubuntu upgrade.

Please help! Im NOT a UNIX pro, so please go slow

Thanks!
MF


#2

I’m having the exact same problem, would really like to know the answer. I’ve submitted a help ticket but no response yet.


#3

Ditto here! Anybody have a fix?


#4

I contacted support and they fixed it for me. I don’t know if the cause of your issue is the same as mine, but here’s what support told me:

[quote]Thank you for writing in to support! I am sorry to hear about your issues
with your domains. There were some lines within your .htaccess file
causing this error, I went ahead and commented them out and am now able
to load your site:

#AddHandler php5-cgi .php
#Action php-cgi /cgi-bin/php-wrapper.cgi
#Action php5-cgi /cgi-bin/php-wrapper.cgi[/quote]


#5

Was this after the upgrade? I think that might have caused it but I’m not too sure.


#6

Catching up… Two things happened.

  1. Moving users to Ubuntu gave us a lot of people who had done minor tweaks like that to PHP in ways that didn’t magically work. Our bad.

  2. WordPress 4.0 is a little more snippy about those things.

The fix made via .htaccess is WP version independent, mind you. That’s just PHP needing to be reminded it’s the new cool stuff :slight_smile: