Xoda install problem

apps

#1

Hi,

I have installed xoda through the one-click installer and than subsequently manual.
Both methods did not work for me (chrome browser, firefox on ubuntu).

I have renamed config.sample.php into config.php and pointed my browser to the directory
www.xxx.net/xoda

I get the login screen.
Typing in admin with password xoda gives me

Warning: Invalid argument supplied for foreach() in /home/frankmattes/myvirology.net/xoda/functions.php on line 432

Warning: Cannot modify header information - headers already sent by (output started at /home/frankmattes/myvirology.net/xoda/functions.php:432) in /home/frankmattes/myvirology.net/xoda/index.php on line 78

As I said, the same happens with both install methods.

I hope someone can help me furher

frank


#2

Hi Frank,

The second warning you got was caused by the first one.
The warning about the ‘Invalid argument…’ should disappear, ones a filter is set for a file/directory or the option ‘Allow additional filters’ is unchecked in the (Settings ->) Preferences.

Here are 2 ways to get rid of this warning otherwise:

  1. comment (or delete) the second line of index.php to become:

[php] // ini_set (‘display_errors’, E_ALL);[/php]
[color=#A9A9A9](The double slash [’//’] makes the line “inactive” as if it is non-existent.)
[/color]
2. replace the function xd_get_fitlers in functions.php with the following one:

[php]function xd_get_filters () {
$fl = shell_exec (‘find ’ . META_DIR . ’ -name “.php" -exec grep -H ‘$_filters’ {} \; | sed -e "s/.php:.$//g”’);
$files = explode ("\n", $fl);
$filters = $_files = array ();
foreach ($files as $f) { if (strlen ($f)) { $_files[] = $f; } }
if (count ($_files)) {
foreach ($_files as $mf) {
$file = str_replace (META_DIR, ‘’, str_replace (xd_basename (ROOT_DIR), ‘’, $mf));
if (file_exists (ROOT_DIR . $file)) {
include ($mf . ‘.php’);
if (isset ($_filters)) {
foreach ($_filters as $_f) {
$filters[$_f][] = $file;
}
}
unset ($_filters);
}
}
}
return $filters;
}[/php]

This was a warning anyway and should not affect the functionality of XODA otherwise. Have fun and tell me what you think about it after a while.

Thank you for reporting this!
It will be corrected for the next release of XODA.

Best,
:slight_smile:
betso


#3

Dear betso

many thanks.

Used method 2, and all working now.

It was not just a error message. I had to re-move the ?login from the url and refresh the browser to get into xoda.

frank


#4

I had the same problem, and used the second solution to fix it. Thanks!