Xdebug 2.1.1 w/ php 53 ? won't detect in phpinfo

apps

#1

Whats up folks.

Thanks again for your help.

Attempting to install the latest xdebug on my dev box (2.1.1) and can’t seem to get it to become detected when i run phpinfo().

I have an old copy of 2.0.5 which if i place in the directory is detected in phpinfo().

I’ve downloaded and compiled the version(even used the phpize from the 53 directory)

I’ve tried with just adding it into the phprc, tried using my own php.ini, basically followed all of the steps here


and here pasting in my phpinfo
http://www.xdebug.org/find-binary.php

Sort of at a loss as to why the 2.0.5 works and the 2.1.1 does not.

Thanks!!!


#2

In a shell, try running:

If there’s anything keeping the new xdebug extension from loading, this’ll display the error message. (Unfortunately, the errors tend to get “swallowed” by FastCGI normally.)


#3

Nice thanks for that tip.

Well I think I know whats wrong, but not knowledgeable enough with the shell to know how to do what I need to.

/usr/local/php53/bin/php </dev/null Xdebug requires Zend Engine API version 220060519. The Zend Engine API version 220090626 which is installed, is newer. Contact Derick Rethans at http://xdebug.org/docs/faq#api for a later version of Xdebug.

The above is what I get from that command.

What I see happening is that the phpize that is set as default is for 5.2.

I deleted the xdebug.so file and the install directory and proceded to try to re-run that process, but using the path the phpize in /usr/local/php53/bin/phpize

But i get the same error message.

Do you know if the ./configure or the make statements need to be run with a specific path in mind as well?

Thanks again!


#4

Follow the instructions laid out here: http://wiki.dreamhost.com/PHP.ini#Compiling_PHP_5.3_extensions. The critical, non-obvious step is:./configure --with-php-config=/usr/local/php53/bin/php-config

Note that this will probably get much simpler as we switch to the next release of Debian Linux (7.0), as we are likely to make PHP 5.3 the default version at that time (in the same way that we switched from PHP 4 to 5.2 for Debian 6.0).


#5

Jeez i’m a stupid!

Thanks a ton worked like a charm!

Appreciate it!