Xcache error


#1

While installing a site on our VPS, Joomla 1.5.9, I enabled the xcache option in the global configs. We got a frontend error as follows:

Warning: xcache_set() [function.xcache-set]: xcache.var_size is either 0 or too small to enable var data caching in /home/.astra/temporary1/replace.worldnewstrust.com/libraries/joomla/cache/storage/xcache.php on line 76

Anyone know what’s up with this? Gotta fix? We are running a custom php.ini(Thanks to sXi’s kick-ass script for IonCube).


#2

First, ensure you have xcache variables set in your local php.ini (open it up and look right down the bottom).

I believe the DH default for xcache.var_size is 256MB, which should be ample.

Maximum Cash Discount on any plan with MAXCASH

How To Install PHP.INI / ionCube on DreamHost


#3

Thanks, Bubba. I did a lot of searching about and discovered that Zend and Xcache cannot peacefully co-exist in the same php.ini, thus causing IonCube to seem like it is working, but is not. Seems Zend will not work with the xcache people on this issue, either. So what xcache says is to try commenting out Zend lines. Well I did. Two of them, the top and the bottom, leaving the one with the xcache.so statement running. And it works.

I have commented Zend out in the past and have never really seen much in the way of a performance difference. I suspect that is because not much Joomla code is Zend-optimized, except for maybe Phil Taylor’s components and we are not going to be using them on the new site.

So all is running well now, a lot of it due to your luverly script. DH should really do the right thing, give you some money and integrate that script into the PS control panel.

You done good, my son. :wink:


#4

Yeah, just comment out the optimizer you aren’t using.

zend_extension="/path/to/ioncube_loader_lin_x.x.so" zend_extension="/path/to/ZendExtensionManager.so" ; zend_extension="/path/to/ZendOptimizer.so" zend_extension="/path/to/xcache.so" Did the VPS xcache Panel switch append any xcache variables automatically to your custom php.ini? If so, it seems odd that it didn’t comment out the ZendOptimizer line while it was doing so.

Maximum Cash Discount on any plan with MAXCASH

How To Install PHP.INI / ionCube on DreamHost


#5

No. Did not. Here’s the thing: in the DH Wiki, one person suggested that turning OFF the xcache switch i the panel and then calling xcache in the custom php.ini was the way to go for IonCube ills.

Guess what? He’s likely right. I did that and Xcache is working fine.

I added the xcache settings I had picked up somewhere.