Www vs not typing www

Hi guys,

My domain is working fine; if a person types in http:www.mydomain.com
;also if they type in www.mydomain.com.
But not working if they type in just mydomain.com in the url box.

Any idea how to get it so that if they type mydomain.com it will automatically go to http://www.mydomain.com?

I have put subdomains such as portfolio.mydomain.com as well, so hopefully that is not interfering(???)

Any help would be great, thank you!!

There’s a setting in the panel which specifies how you would like to deal with this issue. Another option is to use htaccess.

Thanks for your help! Got it solved

Hi guys,
When I created my domain I didn’t know it had a www in it, which I didn’t want, so I found out how to remove it, and did, but then my website wouldn’t appear (too many redirects!), so I went back and, reluctantly, restored the www. But it still won’t appear. It’s a new wp url: makecoffeewritefiction.com. Can someone help me, please. I do not want the www, but if I have no choice, why the hell did they give me one?

We’ll need to know how you enabled, disabled, then enabled it if you want us to help fix it. If you did it via dreamhosts’ panel, it should be quite simple. If you did it via .htaccess, we’ll need to see what you wrote.

I’m guessing that whatever you’re using to run your site has a config setting somewhere that insists on the www.

The easiest solution is to use the DH panel to set your domain to remove the www. And then go through all of your site’s config files to make sure there are no references to “www.” And this includes the .htaccess file (if it exists) that bobocat mentioned.

Ok. I have gone to the DH panel and removed the www. but the message I get when I try to visit my website is that it has too many redirects. Thanks, sdayman, for your help, but I didn’t understand a word. I tried to have a look at the site’s files using Transmit but it told me my login was incorrect.

In my experience, this is usually caused by mod_rewrite directions in htaccess. You might check your log files for hints on what might be causing the redirects. Or post your .htaccess file contents.

Thanks, bobocat. How do I find out the .htaccess file contents?

You can have different .htaccess in every folder. Read them via any texteditor, search them e.g. via “Search” after downloading your whole page - if it isn’t as big. Often you have simply one .htaccess on the root, where also index.html exists.