Www.sitename.com vs sitename.com


#1

I installed Joomla on my site, and started loading different templates.

Suddenly, when switching templates and refreshing, the default Joomla template appeared. Changed to a different template, refreshed, and still saw default Joomla.

Then I discovered that if I put a www. in front of my sitename in url (in the browser), the correct template appears.

???

All the menulinks in Joomla point to sitename.com, rather than www.sitename.com…so that sends the site back to the default Joomla template.

Why did this just start happening? I had made about 20 different template changes without an issue.

Help? I don’t think this is a Joomla issue; I think it’s a domain or Dreamhost issue…just trying to give a good description.

Thanks!
Bill
<><


#2

Well…that’s wierd. In the time it took me to ask that question, the problem fixed itself!

So, I guess this is closed. Thanks for looking! :slight_smile:


#3

I can’t speak for Joomla, but I know that at least Drupal saves site-specific settings (in multiple sites environments) by the hostname. So if the setting were tied to www.sitename.com, it wouldn’t be used on sitename.com (although it works vice versa). Perhaps Joomla does something similar.


#4

somebody had similiar problem before. www.domain.com works but domain.com does not work.

according to the posts in the forum, it takes some time for server to propagate domain.com in the network. maybe it is same for your case

Save [color=#CC0000]$97[/color] (max discount) on dreamhost plans by using promo code: [color=#CC0000]97CRAZY[/color].


#5

It’s kind of fixed itself; now it only happens about 1% of the time, and the rest of the time it works fine.

Strange; but it must just be something to do with the name resolution. Hopefully soon it will work 100% of the time.

Thanks for your responses!
Bill
<><


#6

If you prefer the site to use www. or not use www., you can change the behaviour to redirect to the one you wish to use from the panel, this will remove the problem entirely as the DNS will redirect to the one you’ve chosen.

Go to Domains->Manage Domains. Edit the domain name in question, then set the option you wish to use under “How do you like the www in your URL?”


Web Hosting Review | Hot Product Directory


#7

Thanks, Shonky; I’ll go check that option out!

Bill
<><