Www or not


#1

hi there, this may seem like a trivial question but i have never run into this problem before, and although no where near a pro designer, i am a photographer i just had this problem

so i upload new files/web-pages to my site, yet depending on whether i type in a “www” before the website or not i get either the old pages, which have been overwritten or the new pages or a combo of both. I have reset my browser, emptied out everything, hitten refresh and deleted all old files… only the new files/pages exist on the server…and still this happens, and its killing me…

so what gives, is there some way to fix this…

please help thank you,


#2

This definitely sounds like some kind of caching issue. Since you have cleared your browser cache, the caching must be taking place somewhere else. Are you using a caching proxy server? Some ISPs implement transparent caching proxies to conserve bandwidth, it is possible that this is what you are seeing.

Mark


Web Hosting Reviews | DreamHost Promo Code


#3

One thing you can do is force your site to work without the “www” part. The wiki has instructions for this. Usually, this problem is related to caching, which can occur at more than one point in the network.


si-blog | Keystone Websites
Save $97 on yearly plans with promo code [color=#CC0000]SCJESSEY97[/color]


#4

yeah tried doing that, but the thing is now there are a few pages that regardless of whether i put www or not it is still the old one… and the page nor photo exists on the site…

its all wacky and i cant have people looking at my site like this…

check it out… sakulsky.com will take you to the good version of sakulskyphotography.com although once in the “photography” section things start getting a little weird, especially with ozzfest and paris, the first photo pages dont exist anymore, yet they show up, and when you click to the next you get the “new” design that i just uploaded…

ahhh…


#5

I would’ve had a good look around, but upon being greeted by frames I simply couldn’t investigate any further. :open_mouth:


si-blog | Keystone Websites
Save $97 on yearly plans with promo code [color=#CC0000]SCJESSEY97[/color]


#6

Yep, using frames sure does throw a wrench into the whole thing. It makes it especially challenging to keep digging into your page source to see what’s going on.

If you have your domain set up to use both www and non-www URL’s, try setting it to Add “www” to the domain to force them to all be the same. I always set mine to either Add “www” or Remove “www” to keep things consistent.

-Scott


#7

Have you tried holding Shift while clicking “reload” on your browser? Normally this helps when caching is not being done at your machine, but being done at the ISP or a caching proxy on the network you are.

Both “www.sakulskyphotography.com” and “sakulskyphotography.com” shows exactly the same contents to me, so it really seems to be caching somewhere on your side.

Eduardo


#8

The versions with and without “www” will be separately cached at various places (in your browser, in your ISP’s proxy if it has one, etc.), so may differ temporarily.

Dreamhost gives you several options in its control panel for configurations based on whether you prefer one or the other of the versions of the URL (with and without “www”) to be redirected to the preferred one for you, or left alone to be separately valid URLs of your site.

– Dan