WP Them Contact form not working

wordpress

#1

So I bought a WP theme recently for my new portfolio. Everything was easy till I tried testing the contact form. It says it sends the email, but the email is never received. I have contacted the author and here is his response:

“Please email your hosting provider and ask them if they support the mail() function on your server and if they are using SMTP in the process…”

Now I did some research and have tried numerous things. Please, HELP!

Here’s the link to the in process portfolio www.cesardesigns.com


#2

The mail() function is supported and SMTP is available.

Check the contact form’s settings to ensure your SMTP information is valid.


#3

Now if I have the WordPress SMTP plug in activated and the author is telling me:

“This theme doesn’t support SMTP out of the box. There is a solution however. Download this package: http://rubenbristian.com/downloads/wowway-smtp.zip, and upload it(unzipped of course) in the theme folder. Then open contact-form.php and fill up your SMTP details(lines 38-42, 47):”

Which are:

$mail->SMTPAuth = false; // enable SMTP authentication
$mail->Port = 25; // set the SMTP server port
$mail->Host = “your.smtpserver.com”; // SMTP server
$mail->Username = "name@yourserver.com"; // SMTP server username
$mail->Password = “yourpassword”; // SMTP server password

$to = "your_email@domain.com";

Where do I find what to input for “Port” “Host” “Username” “Password” etc? and do I change the "your_email@domain.com" to the email I want to receive the messages in?


#4

The mail function IS supported, however if you’re sending email FROM an address that doesn’t match your domain, it won’t work (spam protection, yadda yadda).

$mail->SMTPAuth = true; // enable SMTP authentication
$mail->Port = 25; // set the SMTP server port
$mail->Host = “mail.yourdomain.com”; // SMTP server
$mail->Username = "you@yourdomain.com"; // SMTP server username
$mail->Password = “yourpassword”; // SMTP server password

Obviously I don’t know your email or password :slight_smile: