WP Super Cache Makes things slower?

wordpress

#1

A bit of a bizarre experience. I don’t run a plugin-intensive site, but I included WP Super Cache and when the site was slow I was troubleshooting it. Bizarrely, I think the site is faster when I turn it OFF - I don’t get cached pages, but it seems sometimes pages would take forever to generate, wherein now they generate rather well.

The rough status seems to be:
With WP Super Cache I get occasional serious slowdown mixed with pages generating fast (from 8 seconds to under a second) - and of course the advantages of the cache.

Without WP Super Cache, I get consistent good page generation (1-2 second)

On the server I’m on a VPS, doing PHP 5.3, XCache, server and database in the same data center.

WP Super Cache settings were:
Using PHP to serve files
3600 Second Cache timeout
Preload All content with 720 min timeout, all posts (about 5000).

A bit odd, so I figured I’d throw this one out there. I’ve been debating moving to DreamPress, but confess I savor the challenge of doing this on my own as it keeps me technical (became a technology manager ten years ago and I fear getting out of touch).


#2

Did you enable XCache support on your domain?


#3

Caching is a funny thing :confused:

Carnac says … the slowness is when there’s no cached page to serve up. The speed is once the page is cached. Answer? Make your cached pages stay around longer. Many people have their pages expire too soon, so the server’s constantly churning to generate new cache pages.


#4

Actually that variability in the speed is the variability in the cache generating the page - checking the diagnostic code provided by WP Super Cache. Quite bizarre.

I do have XCache on.

I muddled around a bit with the settings, and think I have it working:
PHP to serve files
Don’t cache for known users
Cache rebuild
Extra homepage checks
Preload daily.

Somehow seems to be working this way.


#5

Oh yes, I could have been more clear. The server churn to generate new cache pages is dependent on how often your cache expires, though. So if I visit a page and only THAT page expires, then only that one is rebuilt. But if it’s at the same time as your scheduled cache rebuild, it can take longer.


#6

By now it appears that tweaking the settings has more than alleviated the problem. Maybe it was just One Of Those Things.