WP Site is running very Slowly

wordpress

#1

Hi my client’s new WordPress site:
http://www.keithbrauneis.com/new/home/about
Is running very slowly.
It is slow without any Plugins enabled.

Can you please take a look and let us know what can be done to improve the load time.

Thank you.
-Paul


#2

Two things:

first, try (temporarily) switching to one of the generic wordpress themes and see if it loads any faster
second, log in to your DreamHost Control Panel, and then go here:
https://panel.dreamhost.com/index.cgi?tree=status.dc&

This should show you where your databases and webserver are located. Are they both in the same place? (meaning they both should be in the same datacenter…not the same server)

If your MySQL databases are in a different datacenter than your web services, that can cause some slowness. In which case you can submit a ticket asking them to move both to the same location.


#3

Pwaters, I looked at your account, and sure enough, your MySQL server and web server are in two different datacenters (one on the East Coast, one here in CA).

We’re going to go ahead and copy your databases over to a new server in the same datacenter as your web server, which should speed things up. You should get a notification email once the move is complete. I hope that helps!


#4

Still kind of slow when switching Themes.

You are correct, there are two different data centers.

I will submit a ticket, do you have the link to do so?

Thanks, appreciate your help!


#5

No need to submit a ticket, I’ve already gone ahead and moved your databases for you :slight_smile:

Please monitor the site to see if that helps; if you continue to experience slow load times, feel free to submit a ticket and we’ll investigate: www.dhurl.org/dhsupport


#6

Wow, so much faster…thanks Elle!
I really appreciate your quick help.
-P


#7

My site takes 32 seconds to load. No plugins and lightweight theme. I checked and my Domain and databases are in two different locations! One on kaya and the databases on thayer. Will you please move the databases. Ive opened two support tickets on this:

Message from you (Jan 16, 2014 - 11:35:44 / #6123478)
Subject: In addition to ticket 6123456
I installed a fresh wordpress install and theme install. Here is the result using the test you use:
http://www.webpagetest.org/result/140116_8R_WZN/

37 SECONDS waiting on your server. Why is taking so long to connect to your server when Im not even hitting my limits!!! This is unacceptable. Put me on a different server and tell me what you are going to do to fix this! Ive never had a problem like this! And it is only this site. The “time to first byte” is what is killing which is the wait on your server to respond.

URL: http://www.northportcarsales.com/
Host: www.northportcarsales.com
IP: 141.101.117.32
Location: Cloudflare
Error/Status Code: 200
Client Port: 3808
Start Offset: 0.107 s
DNS Lookup: 78 ms
Initial Connection: 29 ms
SSL Negotiation: 0 ms
Time to First Byte: 29202 ms
Content Download: 236 ms
Bytes In (downloaded): 30.5 KB
Bytes Out (uploaded): 0.5 KB

Please Help!!!


#8

The first load of your page is slow, but subsequent loads are fast (because of caching, I know you know). I noticed that the WP commands we use via WP-CLI aren’t working which means you have some code in your site that’s conflicting. Generally that’s a sign you have a plugin (or theme setting) that doesn’t love our PHP, and that would totally slow your site down!

You have a test page I saw, and that loads pretty darn fast, so I think the issue here is that your WP site is not set up as well as it could be.

Change PHP back to 5.3 - Yes I know 5.4 should be faster, it IS for most people, but not all. This may be the issue.

Also try with some of your plugins off. p3-profiler and wordpress-popup are the first two I’d try.

I saw you have WP Super Cache installed, but you’re using the PHP cache instead of the .htaccess one. I’d switch over, as the .htaccess is faster. Based on this at the bottom, I’d guess you didn’t configure it right for your setup, so you may want to reset the settings and try from scratch (this isn’t that horrible, it’s a fairly simple plugin).

<!-- Dynamic page generated in 10.031 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2014-01-16 16:52:09 -->

<!-- Super Cache dynamic page detected but late init not set. See the readme.txt for further details. -->
<!-- Dynamic Super Cache -->

The last though I have is to TRY PageSpeed. It may work, it may not, but it should do some proxy caching and minification if it does.