WP-o-matic installation


#1

so im trying to make a cron job so i can run wp-o-matic on wordpress

*/20 * * * * /usr/bin/curl http://www.mydomain.com/wp-content/plugins/wp-o-matic/cron.php?code=07d39f95

but i get an error " This field is for the command only, do not enter cron scheduling information here!"

there is also no user name under the “User (shell users only)” section - what am i doing wrong?


#2

Go to Users -> Manage Users and “Edit” the user. User Account Type needs to be “Shell account - allows SFTP/FTP plus ssh access.”

*/20 * * * * /usr/bin/curl http://www.mydomain.com/wp-content/plugins/wp-o-matic/cron.php?code=07d39f95That is a crontab entry, not a command!

The error message explains it all. The Cron Jobs panel is the user-friendly version (“cron for dummies”) of executing commands at certain times. And in this version you enter the command in one field and schedule the times using a different field. And then what the panel will do is use that information to add a crontab entry. See DreamHost Wiki - Setting up cron via the DH Control Panel

Customer since 2000 :cool: openvein.org


#3

I am using the same installation, I installed it and it works fine, here’s the problem I’m having, When it fethces rss feeds and posts them on my site, it’s posting them on my main page (index or home) and I want it to post the entries to an inside page. on my site… How can I do this? Please help.

Thanks.


#4

So in that case, what would you type in the Command section on the Goodies/Cron Job?