WP comment problems

apps

#1

Out of the blue a couple days ago, friends of mine (and I later duplicated the error) started getting an error that said “Sorry, no posts matched your criteria” after they submitted a comment on my site. I’ve gone through WP support, and couldn’t really find an answer that worked for me, or anyone to tackle my question. I wondered if any dreamhosters have had that problem and how I might go about fixing it. As far as I recall, I made no changes to templates or pages in between the time one comment worked and the first one failed.

Thanks!

have you met tony?


#2

Clear your browser cache and cookies. If that doesn’t help, try disabling all active WP plugins.


MacManX.com


#3

As far as I can tell, all plugins are inactive (according to the plugins page of my control panel, and I don’t think I’ve added any others (99% sure). Cache and cookies have been cleared in two different browsers (IE6 and Firefox) on a total of 3 different computers, and the error remains the same.

I did have the “google hilite” plugin activated, but deactivated that a couple days ago when this problem showed up. It shows up as inactive, but is there anything I need to do to make sure its inactive?

For reference, the site having trouble is http://www.haveyoumettony.com

Thanks!

have you met tony?


#4

Your wp-comments.php file is not redirecting you the correct file. It should be going straight to wp-comments-post.php (or the equivalent, if you’ve renamed it). Backup your current wp-comments.php file, delete it from the server, and upload the wp-comments.php file from a fresh WP download. Let me know if that works, If so, I’ll let you know what to fix in wp-comments.php, but first I have to try and remember how to do it.


MacManX.com


#5

Not working so far. Let me try the fresh download of WP and see if that works.

Thanks for the help so far, though!

EDIT: I tried the fresh download (to my computer), and deleted the wp-comments.php file, then replaced it with the freshly downloaded version. Doesn’t look like it worked. (though I know the new one is in there by the formatting of the text field)

have you met tony?


#6

Hm, if you don’t mind, please post your situation over at the WordPress Support Forums. I’d like to hear what the other guys/gals think.


MacManX.com


#7

No problem. I had posted there a couple times, but got no answer. I’ll bump the “Commenting page troubles” thread with an update.

Thanks again!

have you met tony?


#8

Still no response at the WP forums, this board has been my only help.

This is really starting to become more of an annoyance than anything. I’ve now upgraded from 1.2.1 to 1.2.2 (for some reason I thought I was already on 1.2.2), replaced the wp-comments.php and wp-comments-popup.php (though I’m not using popup commenting), and I’m still getting the same error in firefox. Cache and cookies (for my site) have been deleted, and I still get the error.

macmanx, if you’ve got any ideas left in the tank, please help!!! laugh

thanks again!

have you met tony?


#9

Unfortunately, as you can see, the only known solution is to clear your browser cookies and cache. This has worked for every individual on the WP forums. I’m not sure why it isn’t working for you and your readers. Sorry :frowning:


MacManX.com


#10

This is crappy. I’m starting to wonder if maybe I did change something in the index.php file, but I really really don’t think I did. The only thing I remember touching in there at all was how the # of comments is displayed.

If I’ve cleaned out my cache/cookies at least 3 times, and have had other people on many different machines come up with the same error, what step do I take next? Haloscan? Heh. sigh

Thanks for all your help, though, macmanx… it really is appreciated.

have you met tony?


#11

The best way to check would be to backup your current index.php file and upload the default one from a fresh WP download.


MacManX.com


#12

It took awhile, but I got it. Long story short, I had to trial and error my way through not the WP index.php script, but the one that I downloaded with the template I modified. The eventual culprit?

I had switched my archive list from a big list to a dropdown menu, and apparently it didn’t like that. Everything else in the template is cut and paste what I had there all along, but when changing the archive list back to a full month-by-month list (and eventually deleting the gaudy thing!), it worked.

Thanks again for all your tips, suggestions, help and positive vibes, macmanx… just don’t go too far away, okay? laugh

have you met tony?


#13

I will try not to.


MacManX.com