WP 3.5 appearance editor, css, not working

wordpress

#1

Changes that I make to my CSS or files via the appearance editor online, are not resulting in changes on my site. I think it either has to do with the upgrade to WP 3.5 or the server change situation with Dreamhost. I’m not sure which but I’m gonna start going crazy here. Have tried many things over several days.

-I’m not using the actual server name in anything pointing to the Dreamhost servers - using my domain name.

-When I went to the wiki to see how to deal with the media manager in WP3.5 due to the server change - it gave directions that don’t even seem to exist in WP3.5. And basically I could see no problem anyway.

-I used to be able to make changes via the appearance editor

-I tried changing file permissions, didn’t help

-FTP upload of css file does not work either. And even if it did, there is still a problem with the online editor, and it should work.

-I disabled all plug-ins and did and one by one check.

-Even when I switch themes in my Firefox browser it seems the change is not taking effect until I reload several times or log out. I was going to Chrome to see if any change occurred.

-I did a re-install of WP3.5 (but have not tried totally removing all files and starting again)

-I have other sites with WP installations on a shared hosting plan - and the other sites seem to be working ok. But even if I switch themes on the problem site, I cannot make changes to the CSS of that theme either.

Any help would be appreciated. Site is jhicksconsulting.com


#2

Ok - so I just found something and would like someone to explain how this works:
I have a whole directory with my domain name.old (jhicksconsulting.com.old) - and THIS is where my online css corrections are going!!! Can I delete that whole directory?? Do I need to keep it? I assume WP creates this when upgrades come along?


#3

Correct, the “.old” directory is a backup created during WordPress upgrades. You should be making changes in the directory without “.old”, and you can delete the backup if you like.


#4

Why is it that my online editor is even directing itself to the .old files?? It shouldn’t be doing that to begin with.

And I just deleted the .old files - my site is broken now as it was pointing to that directory. I don’t know how to fix this… help! The new install is right there but it’s obviously not being accessed. Instead the .old files are trying to be accessed… and now they are all gone.


#5

For that to happen it would be necessary for something to be directing your site to use the .old directory as the domain directory. I don’t think this could actually happen without having been set manually in some manner.

Take a look in Panel > Domains > Manage Domains

Click Edit next to the troubled domain and make sure that Web directory is set to the correct location.


#6

The webdirectory is set correctly.

The source code of your site points internally correctly:

I noticed you have cloudflare on. Is there a way to tell it to refresh? Maybe that’s what’s up.


#7

The web directory is correct. I checked the config file and it seems right (though I don’t know what all those keys at the bottom are). I disabled cloudflare and that didn’t help. I re-installed WP3.5 through the backend interface online - where I can see most of my stuff but then in "theme"s I can’t see any thumbnail images of the themes. Any other ideas?


#8

But you can see the themes listed? What do you see when you look at the appearance -> Themes page?


#9

I can get into the backend online and see everything. Pages, posts, plugins, files in the editor, etc. BUT it is all really slow - like it struggles to load anything I click on in the back end. Also, I cannot see any images - not in the themes section where you are asking about, and not in the media manager. The list of images is there in the media manager, but none can be seen. When you go to where the image is supposed to be according to the image manager, file is not found. On my site right now you can see the text (if you highlight you see text is there, not just black) - but no images come through and no css is being applied. When I do a preview of any of the themes in the themes section, no css is applied there either. … so it’s looking for css and images in places where they aren’t…? I never used the actual Dreamhost server names but used the domain name. So the changing of servers shouldn’t have affected me.


#10

If you have a regular SFTP client, take a quick look at the owner and permissions of the domain files and directories.


#11

owner is me/mine - permissions had the “group” “write” unchecked so I checked it (because I understood that you can’t edit within WP if the group is not given write permission), and now it’s at 775 for root folder. No change.
[hr]
Actually - when I go to an image on the site that isn’t showing up - it’s path DOES take me to a file that exists. But it’s not showing up on the site. It should be right there. The path is correct. The file is right where it should be.


#12

Ok - fixed!! It WAS a permissions issues. My site has been working fine though for over a year - I’ve been editing and all that. I can only imagine that somewhere between the WP3.5 upgrade and the Dreamhost server change, something happened. Can you explain why permissions would have been changed? Can you also tell me what my permissions SHOULD be? I’m afraid they are too open now. And which files need what permissions - as far as Wordpress goes?

Thanks for all the help. This was pretty much driving me insane!


#13

Yeah permissions can be a hard thing to catch. One little number on a directory and poof nothing.

The “standard” permissions are 755 for directories and 644 for files.


#14

We did have a glitch with the 3.5 auto upgrade for a small number of folks, and it’s possible we did that. If you did a manual upgrade, I blame gremlins :confused:


#15

Thank-you! I’ll look at my files again and re-check permissions. I think I started changing different files all over the place just trying to open things back up again. I did the auto upgrade to WP 3.5, so uh, maybe the tribbles did it. :wink:


#16

Dang it, Scotty, you were supposed to send those to the Klingons!