WP 2.6 Upgrade - Can't get past login

apps

#1

I have several blogs on various domains hosted on DH. I have become lazy and didn’t to any backing up and in haste, forgot to disable plugins before doing the latest upgrade to 2.6.

One blog in particular is not allowing me to see the upgrade page or get past login. Every page redirects to the login page, even after logging in I’m redirected to the login page. The blog itself appears fine, I just can’t login (to post or admin)

I tried renaming the .old to restore my previous install - it didn’t work. Tried all clearing cookies, cache etc and tried it on different computers and browsers.

I’m now at a bit of a loss. I found a thread or two WP forums but nothing helpful so far. I suspect it may have something to do with not allowing www. in urls. It’s definitely cookie related but I don’t know enough to troubleshoot.

Anyone else? What worked? At this point I’m thinking about doing a DB backup and nuking the whole install…and reinstalling. What a pain though!

mail[at]mahalie[dot]com


#2

Is this the “update page” you mention?
http://example.com/wp-admin/upgrade.php

I don’t see a connection between a “www” in the URL and cookies. When all else fails, you can restore your old site, like you did, and then roll the database back one day via the Panel’s Restore DB option.

You can also try to rename .htaccess to .htaccess.sav to see if that clears up the URL issue.

-Scott


#3

.htaccess was a good idea, but it didn’t work.

I slogged through a huge thread on this at WP - it seems it was a plugin (my bad, I didn’t disable them all before upgrading). Renaming the plugin directory automatically disables them - I was then able to login. Woot!

Background
http://wordpress.org/support/topic/188964/page/7

mail[at]mahalie[dot]com


#4

Cool! The rename directory is a nice workaround. I’m glad that WP can gracefully continue if that directory’s gone.

-Scott