Wordpress wp-content folder & uploading images



I installed Wordpress via Dreamhost on Sunday and then transferred my Blogger blog to WP via WP.


The page takes a long time to load because it’s trying to find all of the images. None of the images in previous (Blogger) posts work, and when I tried to post a new image, that doesn’t work (see the most recent post on my blog) either. The images simply don’t show up in any way.

I discovered that I’m having this issue because the “uploads” folder was not created in the “wp-content” folder. However, I don’t have the rights to add a folder on the server. Someone on the WP forums told me I need to get those rights. I’ve searched all over WP and Dreamhost help docs, but I can’t find anything about this.

Why would the “one-click” install not complete the process by installing all of the necessary sub-folders??

I don’t know MySql, but I looked at my WP database and I don’t even see a way to give myself the rights or add a directory to a folder that is not even listed in the DB webview (wp-content).

So, I basically need to know how I can add the “uploads” folder to my “wp-content” folder on the web server. That should fix the problem.


I think you have to create the folder yourself and set permissions to 777. You can do this with a standard FTP or SFTP client, or by logging into the shell with SSH and doing it the old-fashioned way.

si-blog | Keystone Websites
Save $97 on yearly plans with promo code [color=#CC0000]SCJESSEY97[/color]


THat’s how I would fi it, but 755 is sufficient for permissions (it still works, and is “safer”) :wink:



Yes. Sorry. My bad. Am Linux n00b.

si-blog | Keystone Websites
Save $97 on yearly plans with promo code [color=#CC0000]SCJESSEY97[/color]


Ok. I’ve just been using Windows Explorer to look around the web server, so I’ll use WSTP or something instead. Will how to change permissions be really obvious in a traditional FTP client? I’ve only ever used Dreamweaver and Explorer to transfer files.


If you are starting afresh, I recommend you use SFTP to do your file admin work. If you have been using Dreamweaver’s file manager, you will find the interface of WinSCP familiar. You will first need to enable shell access if you have not already done so, and then use WinSCP to perform the same functions as a regular FTP client.

Once you have WinSCP up and running, you can use it to create the “uploads” folder in the appropriate place. You can then “right-click” on any item of the remote tree and select “Properties” in order to change its permissions settings.

si-blog | Keystone Websites
Save $97 on yearly plans with promo code [color=#CC0000]SCJESSEY97[/color]


Enable shell access where? And how?

I hope to try all this tonight.

Thanks for all your help!


“Enable shell access” in his post is linked to the directions in the wiki: http://wiki.dreamhost.com/Enabling_Shell_Access

:stuck_out_tongue: Save up to $96 at Dreamhost with ALMOST97 promo code (I get $1).
Or save $97 with THEFULL97.


Hey, thanks a bunch for the great hints. Everything seems to be set up correctly now…

…except the images I’ve uploaded via WP still don’t show up (heresyourwater.com/wordpress). And, oddly enough, the “upload” directory already existed when I looked at it through shell access eyes. My images are there. The path in the code is correct.

So why aren’t my images showing up?


If you are using the Advanced-Cache plugin, make sure you clear it as well as your browser cache. :wink:

Also, make sure you “posts” imported from blogger don’t reference the images with (now incorrect) absolute URL’s. This is easy to check by loading a post and using the “view source” capability of your browser (or “view properties” when right clicked on an image in FF) and inspecting the URLs used to call the images.

We could help you better at this point if you included a link to your new WP blog, so we could look at the code. :wink:



Someone at the WP forums figured it out for me. It was a problem with my .htaccess file I used to disable hotlinking, which I’ve had a major problem with. I’ll just deal with it later.

Thanks so much for your time!

p.s. I had links to my blog in the other posts, I just didn’t bother coding them as links. :slight_smile:


Yep, that can do it! :wink: Good luck!