Wordpress: Security error code 1000

apps

#1

Using Wordpress 2.3 I am getting the mysterious javascript error ‘Security error "code: " 1000’ when I am loading the options pages for a couple of my plugins (for example “Get Recent Comment” http://blog.jodies.de/archiv/2004/11/13/recent-comments/). When this error is thrown all script on the page dies, which makes the options pages for my plugins almost unusable.

Some debugging leads me to prototype.js (line 1264) but that does not make any sense to me. I have tried everything I can think of, but without any success. I do not get the error when I run Wordpress on my laptop using Apache, just when I have it running on Dreamhost which makes me suspect some security setting. I am using PHP 5.2.2 and the extra security for the domain is disabled.

Is this something anybody has bumped into? Any ideas of what to try to fix this?

Thanks


#2

Have you tried disabling the extra security setting?

$97 DISCOUNT [color=#CC0000]DISCOM97[/color], Double bandwidth or disk [color=#CC0000]DISCOMX2BW[/color]or [color=#CC0000]DISCOMX2SPACE[/color] (worth $119.40pa). More codes


#3

It is disabled, it didnt make any difference.


#4

That sounds for all the world like some plug-ins that need updating to be completely compatible with WP 2.3 (which is pretty common).

Have you checked the WP codex/forums, or with the plug-in authors about any WP 2.3 compatibility issues? Often it takes a few days/weeks for some plug-ins to “catch-up” when certain types of changes are made in a new WordPress release.

–rlparker


#5

There is a post at wordpress.org you may want to keep an eye on. No fix but only been a day. http://wordpress.org/support/topic/139087 apart from that there isn’t really anything else I could find.

You could also try changing the version of php you are using in the panel to see if that makes a difference.

I would maybe suggest disabling all plugins, if this removes the error then enable each one by one to find out if it is a plugin.

$97 DISCOUNT [color=#CC0000]DISCOM97[/color], Double bandwidth or disk [color=#CC0000]DISCOMX2BW[/color]or [color=#CC0000]DISCOMX2SPACE[/color] (worth $119.40pa). More codes


#6

I’m almost willing to bet that WordPress support post was made by the OP! :wink:

Hopefully, someone will find the fix!

–rlparker


#7

Thought it may be but to be honest the only other things i could find on a search was related to mysql errors

$97 DISCOUNT [color=#CC0000]DISCOM97[/color], Double bandwidth or disk [color=#CC0000]DISCOMX2BW[/color]or [color=#CC0000]DISCOMX2SPACE[/color] (worth $119.40pa). More codes


#8

Thanks for the help rlparker & monkeyboy!

I tested all your suggestions and it did turn out to be another WP plugin that caused the whole problem (wp_jquery). That is now disabled and things are working much better. No more mysterious sercurity errors.