Wordpress pretty urls breaks dirs/files having htpasswd

wordpress

#1

Problem started when …
Since Sunday I put up Wordpress pretty urls which uses a .htaccess file to create urls alike ‘http:\mypage.com\nice\url\article’.
I checked wether I could enter my ‘existing/ hard’ files and directories in the directory and I could open and browse them for all, except for files and dirs having an htacces with AUTH…

The issue
If in a directory is another .htaccess file (fancy indexing no problem) having AUTH, the files and the directory will not be invoked. Instead the wordpress .htaccess kicks in and says it’s not a valid post.

It seems
It seems like the wordpress .htacess does not recognize existence of any files or directories having the .htacess with AUTH.

Situation telling
root looks like
/
/.htaccess (of wordpress)
/existingDirectoryWhichWorks
– afileworks.ext
/existingDirectoryFails, wordpress htaccess does not see it
– .htaccess (having AUTH)
– .htpasswd
– filedoesnotwork.ext

Situation and problem re-explain
When I remove the .htaccess having "AUTH"
the .htaccess of Wordpress finds the directory and file and invokes them, so I can browse and open the files. With the htaccess ‘AUTH’, wordpress .htaccess sees the same url as a post.

What did you do with the htaccess?
I’m not an hero with htaccess AUTH and passwd is generated using dreamhost panel and the Wordpress htaccess is generated by Wordpress …

What did I do wrong? :S


#2

bump for solution, I think it’s a good bump
You need to put
ErrorDocument 401 default
in the “.htaccess” file of the protected directory

There are other options and an awesome explanation at
http://www.andrewrollins.com/2008/01/22/wordpress-and-htaccess-password-protected-directories/