Wordpress permalink question

apps

#1

I posted this to support a week ago tomorrow, and still haven’t gotten an answer. :frowning: So I thought I’d try here, and see if anyone knows what might be going on. It’s very odd, because, as I said, I wasn’t doing anything on the site – not even so much as posting an entry – when it decided to randomly stop working. And I find it unlikely that I’ve been hacked, if for no other reason that the fact that creating a completely new .htaccess file did nothing to help the situation. At any rate, any ideas are very welcome! This is about ready to drive me nuts. :slight_smile:

ORIGINAL MESSAGE:
On my blog at http://www.everinjoy.net, yesterday (perhaps before), my permalinks suddenly stopped working (example: http://www.everinjoy.net/16). I checked permissions on the .htaccess file and tried re-making it from inside WordPress (even with various settings as specified in the forum and wiki), but still no luck. It’s like the URL Rewrite command has been disabled or something… it’s very weird, because I hadn’t done anything with the site when it suddenly stopped working.

Hopefully someone there can help me. :slight_smile:

RESPONSE FROM SUPPORT:
Sorry, but I’m not sure what you mean by your permalink. Please let us know what exactly are you doing and what is expected to happen so we can check into this for you.

MY RESPONSE:
Sorry about that, I had figured since WP is a one-click install that I could use its terminology. :slight_smile: A permalink is a permanent link to an individual blog entry, and in WordPress, they’re made using Apache’s mod_rewrite function. DH says in the forums that mod_rewrite is installed on its servers, and up to yesterday, it seemed so. But then suddenly it stopped working. When you click on a link like http://www.everinjoy.net/16, the .htaccess file should read that and cause it to redirect automatically to the post with ID 16. Instead it just redirects to the index.php file, which is what happens when mod_rewrite isn’t working.

Hope that makes more sense!


#2

Actually, you’d get an Error 404 if mod_rewrite wasn’t working. This appears to be something messed up in your rewrite rules. Try deleting your .htaccess file, and this time create new permalinks with this structure:


MacManX.com
I don’t work here. I’m just your typical support forum volunteer.


#3

Weird… I tried exactly that last weekend, and nothing happened. But now it works, so thanks a bundle!

You’re right, I was incorrect in saying that – what I meant was that when I used to use WordPress and b2evolution, before it was offered as a one-click, permalinks never, ever worked properly, and they behaved the same way they did this week. I think I was just a bit miffed at the response I got from support, and got a bit overconfident. (As if I knew anything about htaccess files…) :-\

Thanks again.