WordPress: Permalink and RSS

wordpress

#1

I installed WordPress via the goodies panel to one of my sites.

By default, the RSS 2.0 link points to
http://www.---------.com/blog/wp-rss2.php
which provides the proper RSS Feed.

When I enable the Permalinks feature in WordPress, it changes the RSS 2.0 link to
http://www.---------.com/blog/feed/rss2/
which doesn’t resovle anything.

Any suggestions. I know one thin I can do is hard link the RSS 2.0 link to point to first link above, rather than having wordpress handle it.


#2

/feed/rss2/ is actually the correct feed once you activate permalinks. This is the feed address that almost all WP users use. Are you saying that it doesn’t work? If so, what’s your URL? I’d like to take a look. If it does work, then everything is working correctly. If you have an RSS news reader that doesn’t accept the feed, then it’s time to upgrade.


MacManX.com


#3

ok, I got it working, but now really the way I had hoped.

The site is http://www.digitalphotofrenzy.com

and wordpress is installed in /blog.

When I activated Permalinks, The code included in index.php resolved the RSS feed to

digitalphotofrenzy.com/blog/feed/rss2, which should be correct b/c the blog address is http://www.digitalphotofrenzy.com/blog, but doesn’t work.

what does work is the following, although my blog isn’t in the root folder.

digitalphotofrenzy.com/feed/rss2


#4

Check the two URL values in Options/General.


MacManX.com