Wordpress Livecalendar Plugin

apps

#1

This is, at best, a desperate plea for help.

I am running a Wordpress 1.5 installation on my site. In order for a Livecalendar plugin (http://www.jonabad.com/2005/01/08/livecalendar-10/) to work, I have to disable “PHP as CGI.”

I am as PHP illiterate as they come, and I am seeking some help from the community, since most of you are experienced in dealing with these troubles, to get this to work while keeping the ‘security’ of “PHP as CGI.”

Best I can tell from reading this knowledgebase article (https://panel.dreamhost.com/kbase/index.cgi?area=2933), the script is trying to access something as an Apache Module (using the dhapache user I assume?) as my “name” (theruse I assume) and being met with some stern resistance. However, when it is able to run it as “dhapache” it works just swimmingly.

If I am talking out of my ass and have no clue what I am talking about feel free to hit me with a herring. o_0

Thank you in advance for any and all advice you may offer.
-DR
Http://www.theruse.net


#2

You should contact the plugin developer.


MacManX.com
I don’t work here. I’m just your typical support forum volunteer.


#3

I have been in contact with them. They haven’t gotten back to me, and I don’t know if they have had experience in this field. (PHP as CGI)

I am trying to compare other plugins that do work to see if there are commonalities in calls, but if they are called ‘differently’ in such a way that it is causing it not to work with the “PHP as CGI” setting.

I thought that someone might have a place to start, or just a flat out solution if they understood PHP well.

-DR


#4

Hi there,

There is some info and a fix for getting around the SCRIPT_NAME variable in Wordpress. This might help you resolve the problem you are having

https://panel.dreamhost.com/kbase/index.cgi?area=2933&keyword=php

You can also disable php-cgi and run php as apache (control panel > domains) if that helps.

ok, I see you’ve already found the kbase article, see the user comments for possible fix.

Runing php as apache is not nesc unsafe.


#5

However, it no longer works for running WP after DH’s recent update.

I had to re-enable it to get the site up and running again. And now some of my plugins have stopped working. Looks like I might be changing hosts yet again.

I thought DH was going to be the one. sigh
-DR