WordPress Issue - Slugged Pages & GET

wordpress

#1

Hello folks. I’ve run into a really weird problem with WordPress. It seems that it cannot recognise a page slug, if there are more than 61 characters after the ‘?’ in in the URL.

For example, I have a page at this location:

http://www.correctnesscommentary.com/contact/

This page deterministically displays content depending on what information is fed to it via the URL (GET). I get a 404 error when attempting to go to this address:

http://www.correctnesscommentary.com/contact/?type=list&action=confirm&address=jfell3@wi.rr.com&name=Jim&code=3

However, if I trim the URL back by one character at a time and refresh the browser, this URL will work (with reduced page funcionality because of fewer variables):

http://www.correctnesscommentary.com/contact/?type=list&action=confirm&address=jfell3@wi.rr.com&name=

As you can see in this example, WordPress seems to only be able to buffer/ignore the first 61 characters after the question mark (’?’).

So, this leads to several questions. Does anyone know if this is a reported bug? I tried to report it, but for some reason I couldn’t get into the bug-reporting system. :frowning: Also, where in the wordpress files is this situation handled (variables passed via GET to slugged pages)? I’m pretty good with code, so I could probably fix it myself, if I knew where the fix’n needs to be done. :slight_smile:

Thanks!

Correctness Commentary


#2

This issue is resolved. It turned out that “name” conflicted with WordPress.

Correctness Commentary