Wordpress installation problems


#1

Hi, I’m a friend of the owner of a domain at dreamhost (thenolarundown.com) he signed up with. He gave me access to his account to figure out how to install wordpress and then I’d teach him how to go about that and getting his blog/website rolling.

I’ve been trying since yesterday to get wordpress to work, and I’ve had problems getting it to work.

Here’s what I’ve done:

  1. I did the one-click install of wordpress
  2. I tried accessing the website listed in the email after installing “http://www.thenolarundown.com/wp-admin/install.php” and the website gave me a 404 error. And now it isn’t even loading the page at all.

I don’t understand what else to do to get wordpress to work. I tried accessing the ftp, but the ftp link in the email doesn’t work. It said the ftp link is yourdomainname.com, but when trying to load that in FileZilla, with port 22 and my friend’s original username, it doesn’t work and said “authentication failed”.

I tried using a different username and with a different ftp link “ps162165.dreamhostps.com” and it connected, but I couldn’t find the wordpress folder and could not upload into the home directory, except into the username’s directory.

Does anyone know what the issue is and what to do to resolve this problem with installing wordpress?


#2

You’ll need to set the domain to use the DreamHost nameservers.

ns1.dreamhost.com
ns2.dreamhost.com
ns3.dreamhost.com

#3

Hi thanks for the advice. I changed the nameservers at 1and1 to dreamhost’s servers. I reinstalled wordpress through the one-click method and I’m still having problems taking the next step of setting up an admin user as the link to that part is not working. It says that I could not connect to the website. The link is “http://www.thenolarundown.com/wp-admin/install.php”. Do you or anyone else know what the problem is?


#4

Somethings not quite right, but I’m not sure what.

A 3rd party whois server is reporting your nameservers to be dreamhost. That’s good.
Traceroutes to the IP resolving end up a dreamhost. That’s good.

Could you have possible installed WP in a directory under the domain root, or in the home directory?


#5

Connections are being refused.


#6

I used the one-click install to install to “http://www.thenolarundown.com” without any subdomain and had it automatically create a mysql database. I also installed the deluxe features.

I don’t know how to check if it was installed unde the domain root or home directory. When I go the “manage installed applications”, it says “/” for “location within domain”.

I don’t know why the connections are being refused. Is there a solution to this? The domain is still with 1and1, but I just changed the nameservers to dreamhost earlier today.


#7

Open a ticket. https://panel.dreamhost.com/index.cgi?tree=support.msg&

DNS is done propagating, I checked that earlier.


#8

Are you on a DreamHost Unique IP ?


#9

yes, the website is registered with a unique IP.


#10

If you have Twitter, ping them @DreamHostCare with your ticket number. If you didn’t mention that the domain is on an Unique IP in your ticket, link them to this thread so that they’re aware of that.


#11

ok I contacted support and got a ticket number. What do you mean by ping them? Do you want me to tweet them?


#12

Yeah. If you have Twitter, tweet.

~ It’s a twitter tweet twymphony ~


#13

Hey Amar!

No need to tweet us (I’m on the Twitter team!), I see your ticket. :slight_smile:

Going to have our team take a look, so I’ll keep you updated! Thanks!
[hr]
…And you’re all fixed! It looks like the Apache services (necessary for your sites to be accessible via http) on your private server needed an update. We’ll be emailing you shortly about it. Thanks for your patience :slight_smile:


#14

Alright the website has been fixed. Thanks to dreamhost for the solution!


#15

You’re welcome! If you need anything else, please don’t hesitate to email our team, and/or tweet us @dreamhostcare :slight_smile: