WordPress install not working correctly

wordpress

#1

I originally installed Wordpress to mydomain/blog/, but wanted to change the install to my home directory. So I deleted the blog directory, and used the one-click install to set up Wordpress in mydomain/. However, this new install is not accessing the CSS file, and I can’t login, even though the login credentials are correct. Any ideas?


#2

Well, one of two things happened.

  1. You created your new WordPress and used the old WordPress’s database.

  2. You created a new WordPress and a new Database.

Solution for 1. Login via phpmyadmin and adjust your ‘site_url’ and ‘home’ values. Tutorial

Solution for 2. Empty your browser’s cache and WordPress-related cookies.


MacManX.com


#3

macmanx,

Yes, idea #1 was it exactly – I installed a new Wordpress, but used the existing database (which shouldn’t have had anything in it, as I never actually posted using Wordpress).

However, your tutorial doesn’t really help me yet. I downloaded phpMyAdmin and loaded it up to my site via FTP, but can’t get it to connect to the database. When I try to connect using phpMyAdmin, I receive the following message:

#2002 - Can’t connect to local MySQL server through socket ‘/var/run/mysqld/mysqld.sock’ (2)”

As you can tell, I don’t have a lot of experience with PHP yet. I’m good with CSS, XHTML, etc., and I wanted to get into blogging, so the “one-click install” seemed like the perfect scenario for me. Now if only I could get it to work…

Thanks.


#4

When you ran install.php that put the settings values (such as ‘site_url’ and ‘home’) in your database, so the problem lies there. As a DreamHost member, you all ready have phpmyadmin, sorry I should have said that first. Just login to your control panel, go to Goodies/MySQL, and click your database URL.


MacManX.com