WordPress: Flash uploader emits an HTTP error



I just one-click installed Wordpress. I tried to upload an image using the Flash uploader. The progress bar runs all the way to “Crunching”, then it gives me a “HTTP Error.” and just stops (see screenshot). I can use the browser uploader just fine. Any clues to why this is so?

I checked the apache logs: nothing.




Are you using the Easy Install or the Advanced Install? I use Advanced and have never had that problem.


I’m using the Advanced install too. The only thing I could think of is that I’ve got directory permissions wrong somewhere. :confused: Would you mind doing an ‘ls -R -al wp-content’ for me? If there are things you’d rather people not see, no worries. Thanks.


It’s all 755, and the files are 644. Owned by me, and my group.


I’m having this issue as well. All files have the appropriate perms.

Wondering if it’s related to this FastCGI bug: https://issues.apache.org/bugzilla/show_bug.cgi?id=48554 ?

Any workarounds thus far?
Hrm… weird… nothing in the error logs, but the access logs are full of 401 (access denied) responses:

[12/Jul/2010:13:23:26 -0700] “POST /wordpress/wp-admin/async-upload.php HTTP/1.1” 401 779 “-” “Adobe Flash Player 10”



Do you have HTTP password authentication enabled for your domain, by any chance?


@mavery - Do you have password protection on your site by chance?

I did and I just removed it and re-tested the flash uploader and lo, it works as advertised.

I was getting 401 errors because the Flash Player wasn’t authenticated against Apache (.htpasswd)
(I see 401’s in the logs for the cron daemon as well with Apache authentication turned on)


Yup… See my other post. Any way to resolve that issue? I’ve got the password wall up because we’re not quite ready to go live yet, but we need to be able to seed content during our internal UAT phase.



Yeah, sounds like the Flash plugin just isn’t picking up HTTP authentication from the browser. You’ll have to either disable the Flash uploader or carve out an exception for the wp-admin directory.