Wordpress files not showing up


#1

I created a website and instead of showing me what I see when I got to my wp-admin page, I see an index listing of my directory. This is what I mean:

getyourassinshape.com

When I view my website through https.getyourassinshape.com/wp-admin I see the entire and complete website.

What setting do I change in Dreamhost in order to get my site to go live and actually appear as I’m seeing it through the wp-admin panel?

Here’s what I did:

  1. Created a new domain and added hosting.
  2. Installed Wordpress and did all the set up.
  3. Built the website through the wp-admin link.

Now I need it to go live and appear properly when accessing www.getyourassinshape.com. Thanks.


#2

Your problem is you need to add in your htaccess to redirect port 80 requests to 443 for https…

there are several ways, but i use…

RewriteEngine On
RewriteCond %{SERVER_PORT} !^443$
RewriteRule ^(.*)$ https://getyourassinshape.com/$1 [R=permanent]

which says if the ports not 443 (secure) then redirect to https:

put that in your getyourassinshape.com directory

if your going to use that tho get a real signed certificate too… the dreamhost self signed one will scare people off with the browser warning.
[hr]
btw https://getyourassinshape.com shows your site… it’s just the http that is broken.


#3

Thanks for your reponse LakeRat. I’m not very up on writing code or programming. Therefore, I’m not exactly sure how I’m supposed to post this code. What do I do, write a text file with that code, save it as what? “something.html” and upload that exact file to the main directory? Not sure what I’m supposed to do, exactly, with that code.

I also don’t get why I don’t see any of the Wordpress files in my FTP, since I was able to populate my site with content and I did install WP onto the hosted site using the one click install. Seems strange that it does not appear in the FTP. Did I neglect to make a change somewhere in my setup in Dreamhost?

I just got a professionally signed certificate, too.


#4

The first question is are you using the correct ftp user? Go to the manage domains page in the panel and look at the web hosting column for your domain, it will say fully hosted, User: followed by a user name.

Log into FTP with that user name, and you should see a directory named the same as your domain. Click into that directory and you should begin to see your WP stuff.

make sure the setting in your ftp is set to show hidden files.

In that directory check to see if a file exists named .htaccess if it does download it and add those lines to it, probably at the top should be fine. put the file back on the server. If there is no .htaccess make one with those lines. With some ftp clients you might need to name it htaccess.txt to upload it then you can right click and rename to .htaccess

Also if your going to run a secure site, I would disable FTP in the panel, and use SFTP instead.


#5

I figured out what the problem was. I had mistakenly signed up for secure hosting, and therefore my website was showing up with https://… instead of http://. So of course nothing was showing under http because I had not installed WP under regular hosting.
I deleted secure hosting, reinstalled my files under the regular hosting and problem solved.


#6

Yea I was giving instructions to get it working under secure because that’s what it appeared you were trying to set up.