Wordpress error

wordpress

#1

I installed it from the goodies tab and everything went smoothly and was up and running for a few days. Now today I go to log in and I get this message

Warning: main(./wp-config.php): failed to open stream: Permission denied in /home/.ebonydryer/gauges/lame-industries.net/wp-login.php on line 2

Fatal error: main(): Failed opening required ‘./wp-config.php’ (include_path=’.:/usr/local/lib/php’) in /home/.ebonydryer/gauges/lame-industries.net/wp-login.php on line 2

It seems like a permission problem so I checked the permissions and they were set to 600 so I tried to change them and this is the responce I got.

Response: 550 /lame-industries.net/wp-config.php: Operation not permitted

So I tried to download the file and got this, “Critical transfer error”

I dunno what to do or how to fix it, the only thing I’ve done to my domain since I installed it is checked run php as cgi, could that have caused it and should I switch back?


#2

There seems to be a bug in DH’s WP installer that causes this error at random installations. Contact DH support and they’ll have you up-and-running in no time. Or, you could delete the WP files via FTP, the WP-created database via your MySQL tab, and try again.


MacManX.com


#3

Thanks for the reply but I did figure out what it was. It was ticking run php as cgi that broke it because after I deleted and reinstalled and set everything back to where it was I noticed one of my cgi scripts wasn’t working so I unticked run php as cgi and I got the same error as before. So I had to install again but now it’s up and running. I would like to use run php as cgi though, do you know a way of including cgi in the document that will work? I was using virtual()


#4

I have the same problem myself. Right now I have three WordPress blogs set up… two I installed myself and one set up by the new installer. When I switched over to PHP-CGI the DreamHost installed blog gave me a similar error message.

I think the problem is that the WordPress installer sets the owner:group of the wp-config.php file as 999:dhapache. When you switch it over to PHP-CGI it’s now running as you, not dhapache. So the scripts can’t access the wp-config file, and you can’t access it from your shell.

According to the Knowledge Base >> https://panel.dreamhost.com/kbase/index.cgi?area=2369&keyword=dhapache << something like that happens with FrontPage extensions, and when you want to change ownership they say to contact Tech Support.

Also, I think switching back and forth between PHP as Apache module/PHP-CGI takes a while to take effect… I’d say about 20 minutes each way for me.


#5

I’m running WordPress on a domain that runs PHP as CGI. The trick may be to install while PHP is running as CGI and never change it. You’ll have to talk to DH support about that.


MacManX.com


#6

Turns out that was the problem. I sent a detailed support request, asking if something could be done, and the DreamHost elves fixed everything for me… chowned the wp-config.php file and even turned on PHP-CGI for my domain. Everything now works as advertised.