Wordpress Error: Failed to write file to disk


#1

I can’t upload any Plugins or Media files starting today for some reason.
I am using DreamPress, and whenever I try to upload a file I get this error:

Failed to write file to disk.

Very frustrating as everything was working fine yesterday.

Running Wordpress 3.8.1, with max file upload set to 96MB if that helps.

I’ve tried on all size files, of all types!
Help please


#2

open a ticket via the panel… i bet temps full…


#3

Yeah it was. Looks like you (or someone on the server) had uploaded a couple MASSIVE files via WP (50 megs) and that turffed temp good. I cleaned those out for you. Should be okay, but if you’re uploading files that large, you should open a ticket so we can see about making tmp a little larger for you if possible (if you’re on shared, it may be tricky).

A 50meg image, FWIW, will take up around 100megs of TMP space while processing, and if for any reason it fails mid-stream, the tmp folder doesn’t always clean out properly. Tis a WordPress bug that is known and being worked on.