Wordpress & domain redirect question


#1

so i have my website here: http://nikibrown.com

but i want it to actually go here: http://nikibrown.com/portfolio

when i Specify my web directory:to go here : http://nikibrown.com/portfolio it just shows as the blog with all the css stripped from it.

Not quite sure how to get nikibrown.com to automatically go to nikibrow.com/portfolio

thanks!


#2

Niki, I think you’ve already got it right! Refresh your browser (clear your cache!) - http://www.nikibrown.com/portfolio/
looks fine to me, css and all! :wink:

–rlparker


#3

I know that nikibrown.com/portfolio/ works alright

I just want my reagular website to redirect to that blog.

I originally thought that under manage domains, setting the web directory to /home/username/nikibrown.com/portfolio/ would take it to the blog, which is does, sort of. It takes it to my blog, but it isnt show my theme, or any theme for that matter!!!

Im not quite sure why this is?

Thanks for your reply!


#4

If you are trying to redirect users to http://www.nikibrown.com/portfolio/ after a suitable delay, your best bet is to use the following HTML in the head section of http://www.nikibrown.com/:<meta http-equiv="refresh" content="2;url=http://www.nikibrown.com/portfolio/" />That will cause the browser to jump to the new page after 2 seconds. If you want the redirect to occur without ever having seen the home page, create an .htaccess file in your web root directory with the following:Redirect 301 /index.php http://www.nikibrown.com/portfolio/The “301” indicates a permanent redirect - use 302 if it is to be temporary.

I note that you are moving things around a bit as I type this, so my response may turn out to be irrelevant.

si-blog
Max discount on any plan with promocode SCJESSEYTOTAL


#5

You may need to change the site root in wp-admin. I’m guessing it would have been set to http://nikibrown.com/portfolio/ previously but should now just be http://nikibrown.com. The change you have made under the domain has essentially changed it so the main url is that directory now.

This is found under Options > General.

One other thing may be if you are using wp-cache you may need to clear the cache or remove the line for caching from the configuration file.

$97 DISCOUNT with [color=#CC0000]DISCOM97[/color]
More codes


#6

hmm…still doing this same thing.


#7

Have you tried changing the theme. If another theme works then it could be a problem with the theme itself.

maybe you need to check the css link in the theme header to make sure it is correct.

Normally in the header wordpress themes point to the css with something like

but if you have put a direct link to the css file instead of <?php bloginfo('stylesheet_url'); ?> this would not get updated if you change the sites url.

$97 DISCOUNT with [color=#CC0000]DISCOM97[/color]
More codes


#8

In that case, simply use the .htaccess option that I indicated earlier.

si-blog
Max discount on any plan with promocode SCJESSEYTOTAL


#9

the css link is not a direct link.

Would this be the solution I am looking for? http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory


#10

ah…the .htaccess worked. Thank you!