WordPress can't create uploads directory

wordpress

#1

This is the 1st time I’ve had this problem in the dozen or so WP installs.

I am trying to upload a file to the media library.

Unable to create directory /home/.aussie/noelsaw/coaoc.noelsaw.com/wp-content/uploads/2009/10. Is its parent directory writable by the server?

I’ve tried changing the permissions for the wp-content folder to rwxrwxrwx (777) but that didn’t work either.

Any help is appreciated.


#2

I think the answer you are looking for might be in this previous post.

Also, please note there is no reason to set any directory to “777” permissions on DreamHost, as we use suExec (755 should do), and you really should not do this for security reasons. :slight_smile:

–rlparker
–DreamHost Tech Support


#3

Hi rlparker - I’ve just started getting this error on a WP blog… visited your link from the previous post https://discussion.dreamhost.com/showthreaded.pl?Cat=0&Board=forum_beginners&Number=121879 , but getting an error 404. Would greatly appreciate any direction you can offer… besides the chmod 777 trick (yes I put it back to 755) I also tried to chown -R dhapache:dhapache uploads, but no permission.

Thanks,
jt
[hr]

Hi - NM - I found it. Turns out that I was a flake… yeah pebkac, I know. Solution: I had migrated this site from another server long ago and didn’t realize that I neglected to modify the uploads path. I assumed this was the result of the most recent update, but alas, no, silly me.

Go to: Settings --> Media --> Store Media in this folder and there put the FULL PATH of your uploads, which on Galactus , for example, is /home/username/domain.tld/wp-content/uploads

Thanks for nudging me in the right direction.

Best,
./jt


#4

Yep, that’s totally going to go blarrrg on you :slight_smile:

If you copied the files up via FTP, you may also need to recursively change file/folder permissions. It’ll generally only impact you if you backdate posts (like if I edit a post from October 2010, it’ll put the image in /uploads/2010/10/ no matter what day today is).