WordPress - Blank Pages

apps

#1

I’ve had a problem for a few weeks now, and I’ve tried twice asking at WordPress.org, and got no replies. I thought I’d try here. When I’m in Admin in WordPress and do things like post or edit a post or page, after I click on the submit button, the next thing that comes up is a blank page. It’s not even that; I’ve viewed the source, and there’s no HTML whatsoever, not even . However, the post or page is created, or if it’s a plugin, it seems to activate/deactivate ok. (I get the blank result page after activating/deactivating plugins, too.) I’m using Netscape, btw. I read somewhere that I should disable my ISP’s accelerator, so I did that, but I’m still having the problem.

Furthermore, if I try to view ANY of the WordPress admin pages (even the login page) while I’m in my computer’s admin account, I can’t even get that. I just get the blank window.

Can anyone help? Thanks.

Jen
http://www.SassyDevil.com/


#2

Can you test to determine if it’s an issue with your computer or with your wordpress install? If you can, access your site from an other computer and see if you can get the blank pages to load there. That way we’ll at least have a better idea of where the problem is.

–Matttail
art.googlies.net - personal website


#3

Jen,

What you describe sounds suspiciously like a “classic” netscape quirk - I have seem exactly what you describe many time when netscape tried to render a “broken” table. Many (most?) browsers are very forgiving of improperly formated tables, but not netscape.

I learned this the hard way several years ago when first designing webpages. Is it possible there is a missing “closing” tag some where in your wordpress template/code that could be hanging you up?

I would also suggest trying it from a different browser and seeing if you have similar results.

–rlparker


#4

I can’t believe I didn’t think of that! I got my own computer a couple of months ago, and hadn’t been doing much with my site for a while. I recently installed the newest version of WordPress. I’ll have my boyfriend try from his computer (he’s asleep now). Thanks for that suggestion.

If it were a template–and I’m not saying it’s not; I’m not an expert on PHP and computer languages, although I know a little here and there–I’d think the blank page that comes up with show something in the source view. But there’s absolutely nothing.

It can’t be just Netscape…in IE, the admin pages don’t come up at all. With NS, it’s just some of the results pages that don’t come up. With posting, I believe it’s supposed to reload the same form that I use before I submit the post; the URL in the browser shows “post.php,” just like before I submit it, when it does show. If it were a closing tag, I would think I wouldn’t see the post.php page the first time. But I will keep that in mind.

If things are different when I view on my bf’s computer, I’ll let you know. Thanks for replying. I really appreciate it.

Jen
http://www.SassyDevil.com/


#5

Oddly enough I have been getting that ‘blank page’ syndrome quite a lot since Firefox 1.5 (i.e. appears in 1.5.0.2 and 3) I just give the ‘Go’ button another press and that starts it going again. Must be a carry over from the Netscape engine I suppose.


Norm


#6

Well, my bf can’t access my admin pages from his computer at all. They’re all blank.

Reloading the page doesn’t work, but I tried the “Go” button thing, and that did work! Thanks, Norm. I still want to find a way to fix this, and it wasn’t a horrible thing, since the pages did get edited or created, but I appreciate having the Go option. :slight_smile:

Jen
http://www.SassyDevil.com/


#7

I’m wondering if it’s a problem with your server. Do you have any other php scripts that also return a similiar error?

You might go ahead and put a ticket into support, explanning everything again, and ask if they can check into it. -See if forsome reason php is failing to compile your pages or some such. It’s also possible that apache isn’t sending out the files properly.

I believe the pressing refresh doesn’t work becuase netscape (mozilla) says, it’s a blank page - nothing here. Go actualy requests the page be sent out again, making your sever parse the php again and ship it out. Ctrl-F5 should have the same effect as go.

It’s hard to determine exactly what the problem is. It could be, as I said before, that the server isn’t sending out pages properly. It could also be that you’re suffering some packet loss between dreamhost and your computer, but this doesn’t seem logical. And of course it simply be a browser bug. I’d still contact support and see if they can find anything wrong or shed any light on the situation.

–Matttail
art.googlies.net - personal website


#8

I don’t use other PHP scripts, except for a couple of PHP things that use echo() and include(). Also, the plugins I use for WP use PHP. Some of those come up blank when I edit them, too. I suppose it could be the server, but why would I get no pages in IE and some in NS?

I will email support, though, and see what they say. Thanks.

Jen
http://www.SassyDevil.com/


#9

Hi, I had the same problem. Try to deactivate plugins. Google analytics and Feed Burner ones were making my blog “blank”. Hope it helps!


#10

hi I also have the same problem…
and another problem is I am not allowed to download FileZilla here on my work station… I don’t have PC at home so I only blog when I am here at work…
is there other ways to fix my problem?..


#11

If it’s an FTP issue, you can use Net2FTP/WebFTP from the Domains -> Manage Domains section, or:
http://webftp.dreamhost.com/

-Scott