Wordpress and htaccess

wordpress

#1

I have a advanced one click install of wordpress. I am trying to make my stats accessible. On the wiki I found ‘making stats accessible with htaccess’ I followed the instructions. I downloaded the .htaccess file using the dreamhost webftp, I edited it with pspad and then uploaded it with fileZilla ftp.

When I went back to dreamhost webftp I saw that there was two .htaccess files. I deleted the smaller file (I assumed it was the file without the added code). So only the altered htaccess file remaining. I was still unable to access my stats.

When I checked the site a little later the home page was fine but if I clicked on any link I received this:

Not Found

The requested URL was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

I tried removing the code however this made no difference to the problem

14 hours later I looked back on dreamhost webftp and saw the two htaccess files where visible one with the code and one without. I deleted the one with the extra code. The problem went away and I could access the rest of the site.

Foolishly I tried again with altering the htaccess file and I am back to where I started. I have set fileZilla to ‘force showing hidden files’ I have tried to refresh both fileZilla and webftp to see if there is two htaccess files and an extra one has not appeared.

Help!

Why is this happening?
How do I successfully edit the htaccess file in the future? since this has happened twice now.


#2

I suggest you edit it within WebFTP itself. There’s an Edit link on the right side of the screen in the same row as .htaccess.

Personally, I use Transmit for the Mac which lets me edit it within BBEdit without having to manually download and then reupload it. Much like doing it within WebFTP.

-Scott


#3

Thanks for replying Scott. I will try editing using webFTP in future for editing htaccess.
Alas that doesn’t solve the ‘The requested URL was not found on this server’ issue
Thank You
-David


#4

Go back to wp-admin and under the Settings section, pick Permalinks and set it to what you’d like. Hopefully this will refresh .htaccess. It might wipe out your /stats fix, which you’d need to re-add.

-Scott


#5

yes that fixed everything. That is the crucial bit of the tale I didn’t mention in the first place this website http://www.squidoo.com/wordpress-not-found-error-fix
said to do that and I tried it not making the connection that I had fixed everything

Thank you Scott for helping me out.