Wordpress 2.3.1 Upgrade

apps

#1

I have upgraded my Wordpress to version 2.3.1 using the 1-Click Install. I already received the notice that the upgrade was successful and that the database is already upgraded. The site is working fine but on the Wordpress admin panel, I still get this notification, same as before the upgrade.

A new version of WordPress is available! Please update now.

On the footer, the message is

Thank you for creating with WordPress | Documentation | Feedback | Your WordPress 2.3 is out of date. Please update.

I can’t upgrade again because my Dreamhost panel says

Already v2.3.1!

Anyone encountered the same problem?
Any solution too?


#2

Are you using WP-cache? Have you cleared your browser cache?

–rlparker


#3

No, I am not using WP-cache
Yes, I already creared browser cache, even used a different PC to check the site.

I asked another WordPress user hosted at Dreamhost and he said, he got the same notes/messages.


#4

Yeah, those were just the first “usual suspects”; it sounds like something might be amiss. I’ll try to do a “one-click” upgrade tonight and see if I can duplicate your issue and/or find a solution (if I have a “one-click” install left to play with :open_mouth: ).

Generally, I update all my WordPress installations manually, so I don’t have a recently “one-click” upgraded install to dig around in. Have you considered upgrading WordPress manually without using the “one-click” installer? It’s really pretty simple, and then you know exactly what was changed in your application. :wink:

–rlparker


#5

I might if the issue is not resolved but that would take time since I maintain several blogs. And even if we can do manual installation, it would be best if Dreamhost support is informed of the issues with regards to the 1-Click install since other users might be experiencing the same problems right now.


#6

I agree completely! :slight_smile:

I’ve found a “one-click upgrade eligible” WordPress amongst the sites in my account, and am goint to try to duplicate the issue now. It’s not that I disbelieve you at all, but so I can dig about in the resultant files after the upgrade to see if I can identify the problem. :wink:

I’ll post back with what I find.

–rlparker


#7

Well, I’m likely to not be of much help on this one. I just upgraded a WordPress installation using the “one-click” upgrader and it went without a hitch.

The footer of the Admin page correctly identifies the installation as a 2.3.1 version, and there is no “please upgrade” notice on my site. Everything seems to be reported correctly and the site is working fine.

That said, there must be some difference between my situation and yours (and the other user you indicated reported the same problem). Not that I think it should make any difference, but just to help narrow down the problem, I’m wondering what your previous version was.

Mine was 2.3.

–rlparker


#8

Previous version was also 2.3. Yes, some of my sites went through well, a few did not.

Journey Online


#9

Hmmm. Stranger and stranger. I wonder if DH “tweaked” the “one-click” robot and eliminated a problem that showed up in earlier upgrades? That might account for why some sites had problems (upgraded “pre-tweak”) and others didn’t (upgraded “post-tweak”).

If I had one to test with, I think I’d try deleting the “new” upgraded dir and renaming the “installdirname.old” (as instructed in the robot “sucess” letter for a way to revert) and try the upgrade again to see if it is the installer that has changed or if there is something about the site that makes it “different”. Just a thought. :wink:

–rlparker


#10

It’s OK now. Dreamhost Customer Support solved the issue. Thanks everyone :slight_smile:


Can you post with sense?


#11

Well that is certainly good to hear, but I’m curious: Did they say what the source of the problem was?

–rlparker