Word Press, PNP 7.6 and php-cgi turned off

apps

#1

Hi - I posted before when trying to get phpNuke Platinum 7.6 to work and Artgeek was kind enough to let me know that I needed to turn off the default of php as Cgi for it to run. Got preoccupied with setting that up. Just noticed last night that the blogs I was setting up with Word Press now have this error message:

Warning: main(…/wp-config.php): failed to open stream: Permission denied in /home/.underfoot/fw/featheredwonders.com/flocknotes/wp-admin/admin.php on line 2

Fatal error: main(): Failed opening required ‘…/wp-config.php’ (include_path=’.:/usr/local/lib/php’) in /home/.underfoot/fw/featheredwonders.com/flocknotes/wp-admin/admin.php on line 2

I am assuming this is related. And prior to that the Word Press plugin manager stopped working which I believe was due to DH’s recent policy change that discontinues the use of allow_url_fopen PHP configuration.

I am fairly new to all this and have spent a great number of hours researching how to do this or that - only to have something work and then not work. And of course - I was affected by the Grizzabella issues. I am beginning to get a bit frustrated. While I do expect some problems as I try to learn - it seems hard to decide whether it is me, the programs, the way DH has things configured, etc.

Can anyone shed some light on all this?

While I have not used php on the host for my other website - I did not encounter any problems like this. I have not been comfortable transferring my other domain to DH as a result.


#2

I don’t know much about most of the issues you’re having, but is the plugin section totally non-functional, or are you having issues with specific plugins not working?

I have three installs of WordPress 1.5, and the plugin section still works fine in all of them. But the WPBlacklist plugin did stop working after allow_url_fopen was turned off & I had to work around it.

As far as your other errors, could you set up a subdomain where you run PHP as CGI and try a test install of WordPress there? That might clarify which problems are stemming from your current settings…

Hope that helps a bit!


#3

Hi - thank you for taking the time to answer my question. I can’t get into the two Word Press blogs I set up at all since I changed the default even though that was all I changed. They just produce this error.

Warning: main(…/wp-config.php): failed to open stream: Permission denied in /home/.underfoot/fw/featheredwonders.com/flocknotes/wp-admin/admin.php on line 2

Fatal error: main(): Failed opening required ‘…/wp-config.php’ (include_path=’.:/usr/local/lib/php’) in /home/.underfoot/fw/featheredwonders.com/flocknotes/wp-admin/admin.php on line 2

I will be honest - I am getting increasingly frustrated with this whole thing. I get one thing set up and working only to discover something else won’t work. So I fix that only to discover I can’t access the previous work. I am ready to give up on PHP Nuke Platinum. And I am considering even moving the domain I have at DreamHost over to the web host I use for my other domain since 2001. They have their phone number for Customer Service all over their site and emails. I only used that when I set up at the very beginning years ago. They exchanged several emails with me within one to two hours yesterday on another issue. And they are willing to try to understand more about what I can’t get working here to see if I can get it to work over there. They have CGI Wizards for Word Press, PHP Nuke, Coppermine, etc. etc. And they just decreased their prices and increased their allocations.

Personally - I think the biggest mistake is to suggest we come to a support forum where we get to read the posts of rather unhappy customers and it made me very leery about switching over to Dreamhost as was my intention for the increased space they offer. I was one who was affected repeatedly by Grizabella. And if you are lucky - some kind stranger will try to help you on this support forum as you have. Otherwise - you get no response.

My concerns turned into dissatisfaction rather quickly as a result of this support forum - as opposed to the extremely helpful techs at XO. And it is sad for me - because I was quite positive about Dreamhost at the outset.

Your idea of setting up a subdomain sounds good. I might try it before I decide to change the domain I have here over to the other host. I think it will likely be a means to bring the blogs back. Personally I hate spending hours working on something only for it to go poof.

If I do decide to go that far - I would be curious to know how you worked around allow_url_fopen being turned off. XO didn’t know about that - they run their site differently - but were willing to explore it further for me also - even though it didn’t affect them. I am barely learning php - I am not interested in also learning curl or whatever else until I get more of a handle on one.

Thanks again - and sorry for my rant - especially when you were kind enough to answer my question.


#4

Hope you get it sorted out one way or the other soon… Also, a good place to ask about your error messages would be the Wordpress forums. When I’ve had problems in the past, I’ve nearly always gotten quick and helpful advice, and someone there is bound to be more familiar than I am with what could be causing those errors :slight_smile:

First I messed around with the code trying to change it to use curl instead and got almost nowhere because I know practically nothing about how PHP works. Then I asked the author of the plugin at his forum how I might work around it–the thread is here: http://forums.farook.org/index.php?topic=439.0 (the workaround is specific to this plugin, though, so if you have other ones that aren’t working because of this issue that’s probably no help to you…)


#5

I will check that out - because it would be good to know.

I really don’t think the error is due to Word Press because I didn’t touch a thing except change the default on the php as cgi. I didn’t even realize it for a couple of days because I was so psyched to get PHP Nuke Platinum working finally. I guess the best way to check is trying with a subdomain.

One way or another - I will get it sorted out. But my frustration has just increased. I got the PHP Nuke Platinum installed on the other domain and hit one snag which may be on their end. What I decide with that will likely be based on what they can help me with. I will be installing Word Press over there also and make a comparison.

Thanks again for all your help - and I will be giving your suggestions a try after I take a much needed break from my computer.


#6

If you install some PHP application and then toggle the ‘PHP as CGI’ option it will almost definitely break the application you installed as you noticed. When ‘PHP as CGI’ is enabled your PHP applications run as ‘you’ and have the same permissions you do. When ‘PHP as CGI’ is disabled your PHP does not run as you so they will not be able to access files that are only readable by you. If you make those files world-readable they will be readable by PHP and the application will work again.

In general we have found that people find it easiest to have the ‘PHP as CGI’ option enabled so we encourage that. Unfortunately, PHP Nuke Platinum does not work that way but they are updating it to work properly from what I have heard. A lot of webhosts use this ‘PHP as CGI’ setup like we have, though not all.

  • Dallas
  • DreamHost Head Honcho/Founder

#7

What are the permissions of the wp-config.php file?