Woocommerce Dreamhost Server Issues?

wordpress

#1

I used to host with godaddy, and my ecommerce site…

feywildecosplay.com

…worked great, but was incredibly slow. I switched to Dreamhost and have been experiencing super fast speeds, but my website is so full of bugs and at best is unreliable. The issues I’m having all vary from customer to customer and are very inconsistent. Some of the issues are…

  1. Add to cart issue: When adding a product to my woocommerce cart, sometimes, for whatever reason, I got taken to a page that said there is nothing in my cart. Searching online… I found this:

https://wordpress.org/support/topic/plugin-woocommerce-cart-brokennot-adding-products

Where the first comment is… “Most common cause - PHP sessions aren’t set up correctly on your server (hosting issue).”

  1. I’m seeing tons of users not able to finish checking out through my Verotel gateway. I tested my payment gate out relentlessly across different browsers and platforms, and everything works fine for me, but one of my regular customers showed me this when he tried clicking on the gateway to check out:

https://docs.google.com/file/d/0BzsHTbUrwytxQTRhY0xMYjRMMXdVelVsYXdzTGRSVUR3bGpZ/edit?usp=docslist_api

Again… another random issue that isn’t happening consistently.

  1. Could be completely unrelated but after configuring my SSL certificate, when I use https:// to test my site, often times my page assets won’t load. AKA, I just get the bare minimum with no visual elements.

Honestly, all of these issues only began after switching to dreamhost. They sound trivial, but are costing me hundreds of dollars and are causing me to loose trust in my userbase. Is it possible that Dreamhost has some odd setting that is causing some PHP in woocommerce/wordpress to glitch out? Issue #1 seems to point to that…

Thanks and sorry for the long winded question

-Bryan


#2

You’ll want to use https://wordpress.org/plugins/wordpress-https/ or something similar if you’re using HTTPS. It fixes much of the issues with WP and SSL, which basically boils down to this. You’re having no stylesheets show because you’re loading http CSS over an https connection and your SSL cert is warning your browser that doing so is dangerous and, thus, not loading.

I promise we allow PHP sessions on DreamHost, on ALL our hosting plans even DreamPress. That said, PHP Sessions are the devils work, since they play merry cob with caches.

When you moved from GoDaddy, did you make sure to reset your cache entirely? Different hosts have different file locations, so it’s usually a good thing to nuke the changes in wp-config.php and .htaccess and re-apply them. Also if you made any custom changes in the wp-config for your old host (like defining the file uploads or permissions) you should un-do them.

And there’s the obvious stuff, like you should upgrade ALL your plugins, delete the ones you’re not using, and get rid of things like P3 Profiler if you’re not using them right now. Personally I’d delete the cache entirely, turfing all the files for it like db.php and object-cache.php.


#3

So some of that was a bit confusing. I might need help or specific instructions. But as far as resetting a cache when I moved from godaddy? No I didnt. I dont recall anyways… Well… I have a plugin I use, W3 total cache. I made sure to both, try turning it off, and to try emptying all caches. None worked.

the main thing that is bugging me here is the odd and sporadic nature of these issues that keep cropping up. would any of the things you mentioned here explain why the issues aren’t consistent?


#4

Also, sorry for the double post. But how do I go about “Deleting the cache entirely” and what consequences could this have?


#5

Sorry, I’ve been … swamped :slight_smile:

Since you’ve moved from GoDaddy, check your wp-config.php for lines like this:

define('FS_METHOD','direct');define('FS_CHMOD_DIR',0777);define('FS_CHMOD_FILE',0666);
define('WP_TEMP_DIR',dirname(__FILE__).'/wp-content/uploads');

You don’t need those here. In fact, that second one is a really bad idea.

You should also remove this if it’s there:

define('AUTOMATIC_UPDATER_DISABLED', true);

Deleting your cache the ‘hard’ way would be done by SSH or SFTP. Go in and delete the contents of the ~/domain.com/wp-content/cache/ folder. It won’t impact your site, except that it’ll rebuild the cache.

Generally I suggest people totally uninstall the cache plugins, all the extra files (like /wp-content/db.php and /wp-content/advanced-cache.php and /wp-content/object-cache.php) and reinstall the plugin. That forces it to pick up new paths.


#6

Hello,

Can you confirm that you do not have any more problems with Wordpress woocommerce on Dreamhost ?

Can you also tell me how much cost the needed plugins that are really necessary when setting up a shop ? It’s hard to find good information.
What will be missing in Woocommerce if not buying any plugin ?

Thank you for your help.


#7

Woocommerce isn’t a DreamHost product, so you will need to see their site about paid for features. I am testing a woocommerce install myself and my belief is you can get everything you need to build a shop front, take orders and take payments all for free.


#8

Hello, are you woocommerce shops very slow on dreamhost also ?

even on dedicated !

even without many plugins !

What could be the problem ?

Thank you.