Windows Mysql Connection Issues


#1

I have followed the instructions in the wiki regarding using Mysql Workbench to connect to my mysql database and keep getting connection errors. I am able to connect using an ssh connection from a Mac without issue. I’m hoping that someone might be able to offer some suggestions about where the problem is. Here is what I’ve done so far:

First, I have used Putty to establish an ssh connection from my local machine following the setup instructions given in the wiki (set up the tunnel and then the connection to my domain.) I am able to make the connection there without issue. The shell shows that I am connected to enif; when I run an ls command it shows that I am in the root of my directory structure. Since there should be a tunnel established by the ssh connection to the mysql server, is this what I should see or should I be looking at the mysql server?

Next, I have set up a localhost connection with Workbench. When I do this, and try to connect to the database, I get the following error:

Lost connection to MySQL server at ‘reading initial communication packet’, system error: 2

I have also tried to set up an ssh connection directly through Workbench. I am able to establish the initial database connection, but when Workbench tries to test the settings for the ssh connection, the following occurs:

Connect to host machine is checked blue (success)
Check location of start/stop commands is checked red (failure)
Check MySql configuration file is checked red (failure)

Error: /etc/init.d/mysqld start is invalid

The message log reports the following:

What check_admin_commands

Operation failed: /etc/init.d/mysqld start is invalid

As I said, I can connect to the database with an ssh connection from my Mac without issue so I’m at a loss to understand why I’m getting the errors when trying to connect through Windows 7. I’d like to be able to do anything I need to do with my site from my Windows box so I don’t have to switch back and forth.

Mark