Why would info@ fail?


#1

Hello,

New to DH, developer of 15 years, we’re bringing a lot of our customers over as we can, but have to explain a lot of problems sometimes. :slight_smile:

One of them is a current web app we have that sends email (some details below.) This is on the DH VPS plan, and this web app is configurable. When I set the company email to me@myserver.com, it’s all good, I receive the company copy. As soon as I set the email to info@theirserver.com, it fails, reliably and always.

By fail, I mean the company is not receiving emails. The customer submitting receives their copy and it comes FROM info@ just fine. Just the ones supposed to send TO info@.

I’m not asking that you debug our app, but an answer that something is wrong with the app is outright incorrect too. Like I said, my email, my gmail address, whatever, it’s all good. I’ve tried a few - but as soon as we enter info@theirserver.com as the company email, boom, no email. Something is “up” with this email account - OR - are there email filters that are killing any sends to info@?

Note also that we’re not sending to and from the same address - company emails are from the customer, to info@, customer receipts are to the customer, from info@. They are processed in a loop as two separate sends, not as CC’s or BCC’s, and I have experimented with switching their order - sending the cust.copy first and vice versa, in case it was some limitation on how often an account can use the mail server (which falls down anyway if I can do it with my email address.)

To pre-answer some of the questions, yes, we’ve verified info@ works fine with normal email, and no, I haven’t looked into the mail server logs yet, sorry. Like I said still new with DH and am still “adjusting” to the interface. The DH interface, in respect to most settings, is at defaults except for the PHP setting (below,) but if any of these values would be helpful I can post them.

Some answers about the app, but it’s not likely helpful, this is a modX CMS (PHP, and using 5.3+) with a custom snippet used to manage an order form. I know the code for the snippet intimately as I wrote it and have done lots of testing/debugging trying to sort out why it’s not sending to info@.

One unanswered question from the client I haven’t gotten yet - I do not know if they are using the same domain for testing, that is, using someone@theirdomain.com as a customer. Is it possible that it’s the send to and send from being the same domain is screwing things up? You can see, it makes no sense to me and I’m grasping at straws.

To further “defend” that it’s not the app, :slight_smile: there are other simple forms on the site unrelated to this that have info@ as the recipient, managed by the modX Formit plugin - these are failing also, but only for info@, and are “solved” in the same way, with different email addresses.

Any other email, happy as a clam. Set these to info@ - it fails, but just from web forms/processors.

Got ideas?