Why wasnt cgi-bin created?


#1

I am setting up a site for someone here…I added the new domain but the cgi-bin wasnt created? also,…does thesew acounts come with ssh access so i can install At3?


#2

Dreamhost operates under suexec, which allows scripts to run as your user instead of the webserver’s user. This obviates the need for a dedicated cgi-bin, as you can run scripts from any directory with permission set to 755 for the directory and the script. If it makes your xfer of sites easier, just make your own cgi-bin directory, and set it to 755 permissions.

All Dreamhost accounts come with ssh access available at no additional cost, but the user must be shell-enabled in the Control Panel for them to access the shell via SSH.

The following DH Wiki links should help explain some of these issues for you:

Suexec
Shell
CGI, PHP, and Databases
cgi-bin

–rlparker


#3

thanks for the info…I am not usedto these constraints… I have a couple of dedicated myself…

But one more thing… the SmartThumbs server check script is rerturning a few errors with the server config. rub thisand it will show you:

http://www.trannysextgp.com/st/sc.php


#4

From that report, it appears you will need to make some changes to your PHP environment to facilitate the script.

[quote]Output Buffering ? On
(Error) Output Buffering must be disabled or you will experience timeout issues.[/quote]
This can be modified for your domain by either compiling your own custom version of PHP for use on your domain, or setting up your domain to use a customized php.ini file with the default DH installations of PHP.

[quote]Register Globals ? Off
(Error) If you want users to be able to upload images, then register globals must be enabled. This will require an entry in .htaccess or a php.ini setting.[/quote]
This can be addressed in the same manner described above, but I strongly recommend against setting Register_Globals = On, as this can present a significant security risk to the server running such a configuration.

–rlparker