Why has Apache on my VPS suddenly become very slow

vps

#1

Recently my VPS Apache file transfer speed has become horribly slow. Downloading a static 9 MB file takes about 10-20 minutes. I only switched to a VPS a few weeks ago. I never experienced anything like this on shared hosting. The VPS itself was fine up until yesterday. Dreamhost support appears to be MIA. I tried the live chat, but that person seemed to think this was normal.

The problem is entirely confined to Apache on my VPS. I can scp the same file in 4 seconds. Therefore, there is no bandwidth issue between me and the server.

I have temporarily solved the problem by moving important files to an AWS S3 bucket and changing my links to point to that. That download takes 4 seconds, as expected. Obviously, moving the rest of my files to AWS will solve the problem. But moving domain names etc. is going to be a lot of work. The rest of my website is still slow. Is there some magic, non-dialup speed setting that I can enable in an .htaccess file? I tried “EnableSendfile Off” in an .htaccess file but it didn’t have any effect. It seems like it has got to be some kind of config file issue. Having a managed Apache environment seemed like a good idea before. Now, not so much.