Why does ruby install require sudo?

apps

#1

Following the instructions on Dreamhost’s wiki, I tried to upgrade ruby to a more current version using rvm:

rvm install 2.0.0

but the install requires the sudo user password:

Searching for binary rubies, this might take some time.
Checking requirements for debian.
Installing requirements for debian.
Updating systemriccas7 password required for ‘/usr/bin/env PATH=/home/riccas7/.gems/bin:/usr/lib/ruby/gems/1.8/bin:/home/riccas7/.rubies/bin:/home/riccas7/.rvm/bin:/usr/lib/ruby/gems/1.8/bin/:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/games:/sbin:/usr/sbin:/usr/local/sbin apt-get --quiet --yes update’:

which, of course, I don’t know…has anyone figured out a way around this? Seems strange that rvm should require sudo, which I thought was a general no-no in using rvm.

Thanks…
–rick