Where is httpd.conf in a dedicated server?

vps

#1

Sort of newbie-ish at this. I need to increase the Timeout directive to avoid Gateway Timeouts while running cgi scripts that take a long time.

(Feel free to reply “no, dummie, you need to do XXX instead”.

Thanks!

Armin


#2

I can never remember that eaither :wink: So thankfully there’s find!

That came up with a lot of cruft and the following:

/usr/local/dh/apache2/template/etc/original/httpd.conf
/usr/local/dh/apache2/template/etc/etc/original/httpd.conf
/usr/local/dh/apache2/template/etc/etc/httpd.conf
/usr/local/dh/apache2/template/etc/httpd.conf

Most likely you want /usr/local/dh/apache2/template/etc/httpd.conf


#3

Found it. Thanks!


#4

Note that your server’s httpd.conf will be overwritten periodically by our management tools — there’s ways to disable that, but doing so will also prevent you from adding new domains or whatnot from the DreamHost Panel. Hardly ideal.

I believe the Timeout is set pretty high by default. What are you doing that’s hitting the limit?


#5

I have a Movable Type blog that has a very big archive, so anytime I save an entry and it triggers the CGI script it will execute for about 2-3 minutes and then blurt out a Gateway Timeout. I tried a cronjob for the archive template and that solves the template not timing out, but it doesn’t solve that every entry has to rebuild the archive template itself, so it times out.

Any awesome ideas?


#6

I’m not as familiar with MT as with WordPress, however I would think they should have some sort of plugin/extension to prevent rebuilds on save, in that case. I just don’t know where to look.