Where are $PATHs? not in .bash_profile


#1

Hi:
I’m also a newbie and have problem getting CAKEPHP console to work. I did some searches (on here and elsewhere) and found that I need to add cakephp path as $PATH to my .bash_profile file.

However, if i do a ‘vi .bash_profile’ I see no path entries in it even though I can see the paths when I do ‘echo $PATH’

Question is: Where can I see $paths to ensure when I add the CAKEPHP shell path it will work?

OR any other advise to get me going on the CAKEPHP shell ‘baking’ would be appreciated.

Thnx in advance.


#2

There are default paths on each account. Those are the ones you’d be seeing when echoing without setting up any cusotm ones. You can add extra paths to your .bash_profile and .bashrc files and they’ll be parsed by the server on a per-userspace basis.

Maximum Cash Discount on any plan with MAXCASH

How To Install PHP.INI / ionCube on DreamHost


#3

Thanx MAXCASH.
I’ve added the CAKEPHP console as below but getting ‘No such file or directory’ error; (‘myusername’) is not actual:

PATH=$PATH:/home/‘myusername’/website_files/cake/console.

But I do confirm that CAKE-php (shell) console is sitting at the above location on my space.

Do you see any mistake in the above?

Pls help.


#4

I’m not familiar with CAKEPHP, but you might try:

Maximum Cash Discount on any plan with MAXCASH

How To Install PHP.INI / ionCube on DreamHost