What version of PHP should we use for wordpress?

I just got a Yoast newsletter that says that people should not be using old versions of PHP such as 5.2. My Admin panel says I am running the DH-recommended 5.6, but there are several versions of 7 available. Should I move to one of the versions of 7, and if so, which one?

This is what Yoast wrote:

"Please update to at least 5.6, but rather PHP 7 to take advantage of all the awesomeness of this new version. Not just for you as a user, but for developers as well.

The why is three-pronged: security, speed, and future-proofing. PHP 5.2 hasn’t been updated for years and has serious issues. PHP 7 is lightning fast, up to 400% faster than 5.2. You might even regard this as a green move; you can use 50% fewer servers to get the same results from PHP 7. Last but not least, developers can finally use all the modern technologies to bring WordPress to the next level"

if i posted this in the wrong category, can someone move it?

WordPress itself recommends PHP 7:


PHP 5.6 will only get security support for another year, so it makes absolutely no sense not to upgrade:


Keep in mind that if you have not updated WordPress core, themes, or plugins for a while, or you are using themes or plugins which have not been updated in a while, things can break (and probably will). But from a security standpoint, you really should keep everything—PHP, WP core, themes, plugins, etc.—as up to date as possible.

PHP7 is better for WordPress.

Thank you both for your replies, I will do the upgrade (and report back here if I hit any snags, altho that sounds unlikely).

Upgrade to PHP 7.0 FastCGI seemed to work fine. I asked DH support why the dropdown in the admin panel says “PHP 7.0 (new and scary)”. They said they do that because your WP theme might not be compatible.

Since I’m using Twenty Sixteen, I figured that was not a problem, but i guess there could always be an issue with a plug-in. oh well. The only thing holding me back was that “new and scary” warning…

Thanks again to y’all for your help and responses.

Unfortunately, nonsense like this is one of the things that actually prevents people from upgrading, which they should. I still run into people who are using ancient versions of WordPress (core, themes, and plugins) and can’t figure out why they keep getting hacking.

It would be far better if DH linked to a page in the knowledge base that explained the benefits of updating and the potential pitfalls of suddenly updating from ancient versions of software. It’s fun to be clever; it’s more important to be precise and useful. At this point, PHP 7.0 is far from new, and it’s well documented enough that it shouldn’t be scary. Sigh…

  • end of rant*

and unfortunately they put things like “new and scary” and then forget to remove it…

If you want my rant, if the word “New” is ever used it should be auto-expiring.

And “scary” should be turned into “Beta” if they want it tested.

its a good thing i read this, :expressionless:
mine is 5.5 :smiley: