Weird Redirection


#1

Users can only view my website by typing in the full URL https://stefanarmijo.com. When I enter stefanarmijo.com, I’m shown the ‘This domain is parked’ kitty cat page. The domain was parked at one point but I unparked it several weeks ago. Also, when I enter http://stefanarmijo.com (not HTTPS) I’m redirected to stefanarmijo.com and the parked domain page.

Is there a setting I have to enable/disable or is it something that has to do with redirection? Or is it because I’m using HTTPS?

Thanks!


#2

ahhhhh Parking. I don’t understand why it exists, and I don’t understand why so many people are attracted to play with it. I know of not one webpage, textbook or tutorial that recommends using a “parking” feature at your host.

Add in the fact that dreamhost buries a DNS change into the mix that could take 4 hours for invoking or revoking your parking choice. (DNS Change that is transparent to the user, the user doesn’t realize “this panel change effects DNS entries” and because of that it might take 4 hours to propagate.)

Make sure that your domain says “Fully hosted” on the manage domains page of the panel, yours seems to confusingly still have a park element. (EDIT: I’m not actually seeing kittykat page on your http side, you might just need to ctrl-f5 reload the page from server.)

For HTTP to redirect to HTTPS: you need to add a conditional redirect manually to your .htaccess file. (you can google many different versions of this code snippet that all do the same thing essentially, this is the one I use).

RewriteEngine On
RewriteCond %{SERVER_PORT} !^443$
RewriteRule ^(.*)$ https://EXAMPLE.COM/$1 [R=permanent]

Change EXAMPLE.COM to your domain.

It says “If Server_Port is NOT 443 then redirect to my HTTPS site.” Other versions you find on google may redirect port 80 requests, instead of “NOT 443”. The $1 preserves and passes any URL extension.

With the code snippet in place in your domains .htaccess file then pointing your browser at an http URL for your site will redirect to HTTPS preserving any url extension.


#3

Probably the practice comes about as an advertising feature for web hosts - but since Dreamhost does this when you fully host too, may as well fully host a new domain anyway


#4

Yeah, everything went awry when I parked my domain for a few days. remind me never to do that again.

The parked kittykat page is gone and I can see my site’s directory but only two files are visible: favicon.gif and favicon.ico. Can’t see any other files or directories. And, the most annoying part is my simple little index.html isn’t being rendered for some reason.

Everything still works when I point my browser to the HTTPS URL https://stefanarmijo.com.

I don’t know if this is relevant, but in my DreamHost Cpanel, in Domains > Secure Hosting there are two SSL certificates, both for stefanarmijo.com. Should I delete one of them?

Also, in Goodies > Httaccess/webDAV under where it says “Please select a fully-hosted domain below” I see the following:
http://stefanarmijo.com
https://stefanarmijo.com
https://stefanarmijo.com

The HTTPS domain is listed twice. Did Break something when I was messing around?

Thanks again!


#5

I think you have some weird combination for the “www” or “leave it” settings. Don’t pick either if your going to use HTTPS. I always use “Remove WWW”

I note that if you go to the https site it forces www, whereas on http if specified it’s removed.

if after reading this the answer is not obvious, either give us a screenshot of that section of the manage domains page of the panel or as support to check your settings.

As far as the htaccess snipit that I gave you above, you have to manually place that in a file called .htaccess at the root of your domain, for example /home/USER/stefanarmijo.com/.htaccess You can’t use the htaccess part of the panel for that.


#6

Support via live chat helped me with weird duplicate SSL certs and duplicate domains under Goodies > Htaccess/webDAV. I created and edited the .htaccess file the correct way but I still can’t see my web page proper at the http URL, I’m only seeing the directory like this: http://i.imgur.com/7VQSYjH.png

Not only is my page not rendering, there aren’t any subdirectories or files visible in the browser. I really don’t understand what’s going on.

Everything works fine via the https URL.


#7

Something is still goofy tho, you mentioned that should have an index.html and it’s empty.

On manage domains in the panel, there is a USER name is the web hosting column. Does that user name match where you put the index.html file?


#8

Oh that’s so annoying. Yes thank you for pointing that out. It’s hosted under with a different random user name. I don’t think I would ever have caught that!

I’m moving the site to the proper user name directory. Hopefully that works.


#9

Yep that was the problem. Under Domains > Manage Domains then Users, Files, and Paths I set ‘Run This Domain Under The User’ to the proper user and that solved all my troubles. Consider this issue solved!

Thanks again!