Weird FTP problem


#1

I’m new to Dreamhost, but not new to hosting, shell accounts, FTP and all that.

I’m experiencing very strange problems with FTP. In short, the DH’s ftp server drops the line within a few seconds after connecting. Sometimes the connection is lost even before my ftp client gets the first directory listing. But it always drops the connection within 30-40 seconds, making it impossible to upload my files. Short files make it through (though I have t reconnect every minute or so) but larger files never do. I have tried three different ftp clients (on Win2K), disabled the firewall, tried all the usual tricks, but no change. Setting the ftp client to passive mode doesn’t help, either. My website has a few hundred files, big and small, and this behavior is rather annoying…

Has anyone experienced something like this?


#2

Hi marek -

If you can, please see if you can use a ‘traceroute’ utility on your domain. This will be very useful in determining if there is some sort of intermittant network problems between your computer and us (also, if you have seen - or haven’t seen - similar problems with your shell access, let us know that as well).

Basically, the more details, the better! :>

  • Jeff @ DreamHost
  • DH Discussion Forum Admin

#3

Thanks a lot for replying, Jeff. I’m including the traceroute below, it looks mostly normal, except it’s long and arduous because I’m in Poland :slight_smile: Note I’m using annie.dreamhost.com, because the domain I own has yet to be changed to point to your servers. I have no trouble accessing DH via the web or telnet/ssh.

If the transfer was merely slow, that would be normal. But the ftp server, or something along the way, seems to be actively cutting the connection all the time.

Here’s the traceroute:

IP address Host name Round trip time

1 1.64.0.1 Unavailable 651 ms
2 192.168.64.1 Unavailable 0 ms
3 217.172.225.169 225-169.gdynia.mm.pl 10 ms
4 153.19.102.193 Unavailable 10 ms
5 195.94.194.53 z-gdansk.pronetcom.pl 20 ms
6 217.153.3.209 waw-p2r1-pos3-2.ipartners.pl 30 ms
7 217.147.97.61 sl-gw10-fra-8-3.sprintlink.net 50 ms
8 217.147.96.37 sl-bb20-fra-8-0.sprintlink.net 50 ms
9 212.162.44.89 Unavailable 60 ms
10 195.122.136.34 ae0-12.mp2.Frankfurt1.Level3.net 70 ms
11 212.187.128.25 so-0-0-0.mp2.London1.Level3.net 70 ms
12 212.187.128.153 so-1-0-0.mp2.NewYork1.Level3.net 140 ms
13 64.159.0.246 so-1-0-0.mp2.LosAngeles1.level3.net 211 ms
14 209.247.9.154 gig11-0.core1.LosAngeles1.level3.net 201 ms
15 209.244.10.134 gigabitethernet4-1.ipcolo1.LosAngeles1. 211 ms
16 63.208.231.118 gw-l3.sd.dreamhost.com 211 ms
17 66.33.213.10 annie.dreamhost.com 200 ms


#4

Jeff, one more observation.

I’ve just tried uploading through a secure connection, using WinSCP. The same thing happened, although the connection stayed up for a minute or two, but was eventually dropped by the DH server. I realize I’m physically on just about the other side of the globe, but I’ve never seen a server actively drop connection in this way, where “never” means 7-8 years I’ve been using remote shell accounts.

I’m quite worried, because I absolutely love what I’ve seen of the setup and tools DreamHost provides - yet atthe moment I have no way to upload even a single file if the file needs more then 30 seconds to get through.

(I could only test www access before signing up, of course, and it was excellent; and ping times were consistently better than pings to my previous provider, located in the UK)


#5

Hi marek -

That definitely does seem weird, esp. since your shell sessions are uninterrupted. Obviously, it’s not proper behavior. I’ll have to defer to our Admins on this, though, as I’m not an expert on our ftpd.

You should definitely contact Tech Support and file a ticket, at the very least. I’ll see if I can get any more info to you (or maybe have Will take a look when/if he has time).

In any case, there’s a 30 day money back guarantee that we offer with all plans. If we can’t get you up and running reliably, let me know and I’ll make sure you get your money back (of course, hopefully that won’t be necessary!).

  • Jeff @ DreamHost
  • DH Discussion Forum Admin

#6

Thanks again for replying, Jeff. I’ve had mixed luck with FTP, though I’ve eventually managed to upload the website. I’ve discovered something interesting though, which may have a direct relevance to these disconnections:

In an SSH session, when I run a shell command or program, the process occasionally receives a ‘kill’ signal. The first time it happened when I launched Lynx - after a few seconds Lynx quit and wrote “Killed” to the console. I gussed maybe you guys don’t like Lynx :slight_smile: and thought nothing of it. But later, I uploaded my HTML pages as a single zip file and run unzip in it. Half-way through unpacking the file, the unzip process got killed in the same fashion - now this was truly weird!

So something is killing processes, apparently at random, in my SSH sessions. (It happens rarely; most of the time I have no trouble using the shell.) That something could also be killing my ftp sessions, causing those random disconnects, couldn’t it?

.marek