Website not showing up


#1

I transferred a web site from another hosting company to DreamHost. I thought I did everything right.

  1. I created a folder, with the same name as the domain I wanted to move over, in the “root” directory (the one that lists the domain I already had here, plus logs, mail and MailDir).

  2. Uploaded all my files to that directory.

  3. Created new domain in the Add Domain section.

  4. Went to manage.opensrs (I forget exactly what it was, but I know it was the right place) and changed the DNS to Dreamhost. (transferring the actual domain will have to wait, right now I just wanted to get the DNS changed)

I know that worked because when I go to Whois and put in the domain I transferred the dreamhost nameservers appear. But when I type in the domain name in my browser, I get an index, with no content.

So, ok, I thought that instead of creating a folder name in “root” (I know it’s not the real root) I need to create the folder in the root of my current domain, so I did. I created a new directory within my original Dreamhost account domain name, and uploaded one file. If that was the correct thing to do, then that file should show up on that index page, but it’s not showing up.

So basically, I’ve “lost” my entire domain and I don’t know what to do. What did I do wrong? What did I not do? What should I do? My web site, the one I moved over, isn’t a business site but it is visited by people every day, and now they’re just getting an empty index page.

The domain is wretchawry.com. I have two other domains that I transferred over with the same thing happening, but that one is the most important. If I get that worked out I can do the same thing with the others.

Please help.


#2

Don’t worry, you haven’t lost any files yet. :slight_smile:

You only have one unix username/account, right?

Use the [color=#CC0000]3DOM50[/color] promo code for 3 extra lifetime domains and $50 off
More Dreamhost coupons here!


#3

You do not need to create folder by yourself. When you add a domain in DH panel, a folder will be created automatically.

And your files should go to /home/yourusername/yourdomain.com Note the user name does matter. It should be the FTP user name created for the domain.

I suspect you have uploaded the files to wrong folder. Can you try DH panel --> Domains --> Manage Domains --> WebFTP, it goes to your domain’s root folder. If there is no file inside, please try to re-upload your files to this folder.

Note: if you log in via FTP, you will go to your user’s root folder which contains “Maildir”, “Logs”, “yourdomain.com” folders.

$50 off and 3 free domains with code: [color=#CC0000]DH3[/color] Sign Up NOW or More Codes Here


#4

Lensman, right, I have the main account that I got when I first got my Dreamhost account. I don’t use it for anything. I got the Dreamhost account so I could host another site (suspended-in-gaffa.com) here. It had been with PowWeb but I was unhappy with them so wanted to move it here. I could have just moved the domain without getting a new domain upon signup, but since a domain was free I went ahead and got it. I moved over suspended-in-gaffa.com and everything’s been working fine for the last two years. I didn’t think I’d have any problems with these new domains.

patricktan, the problem is that I can’t find the directories using WS-FTP, the program I use to upload files.

[quote]Can you try DH panel --> Domains --> Manage Domains --> WebFTP,

[/quote]

Ok, I just did that, and I see the folders I created. I click on the new one I just added, and I see all the files that I uploaded…wait…

Let me tell you exactly what I’m doing. I’ll switch back and forth from another screen to this one as I do each step.

  1. I go to https://panel.dreamhost.com/ and log in

  2. I click on Domains over to the left

  3. I click on Manage Domains

  4. Listed there are the 7 domains I currently have hosted on Dreamhost (1 original, 2 that I added some time ago, and the 4 new ones.

  5. I see this for the most important new one:

wretchawry.com
DNS | Visit | WebFTP | FTP | Add IP

  1. I click on FTP, log in, and see this:

Index of ftp://wretchawry@wretchawry.com/

Up to higher level directory
Directory: Maildir 2/19/2008 12:03:00 PM
Directory: happyrhodes.org 2/21/2008 1:42:00 PM
Directory: logs 2/21/2008 1:43:00 PM
Directory: rhodeshows.com 2/21/2008 1:41:00 PM
Directory: rhodeways.com 2/21/2008 1:43:00 PM
Directory: wretchawry.com 2/21/2008 1:40:00 PM

  1. I click on wretchawry.com and see an empty directory.

Now, let me back up to the screen that shows the 7 domains.

  1. I click on my original domain name, and see this

Index of ftp://equipoise@rhodesongs.com/

Up to higher level directory

Directory: Maildir 5/24/2007 12:00:00 AM
Directory: happyrhodes.org 2/20/2008 10:15:00 AM
Directory: logs 9/9/2006 12:00:00 AM
Directory: mail 10/14/2006 12:00:00 AM
Directory: rhodeshows.com 2/18/2008 11:54:00 AM
Directory: rhodesongs.com 2/28/2008 10:00:00 AM
Directory: rhodeways.com 2/28/2008 9:48:00 AM
Directory: suspended-in-gaffa.com 1/19/2008 4:38:00 AM
Directory: wretchawry.com 2/28/2008 9:23:00 AM

  1. I click on wretchawry.com there, and all the files that I uploaded are there. I created those directories so I could upload files. Do you think my “real” domain isn’t showing up because the directory I had created is blocking it or something? I created those directories before I did the Add a New Domain thing. If I delete wretchawry.com (the one I created with all my files in it) will wretchawry.com (the empty directory) suddenly appear?

I hate to do that. It took me days to upload files, but I will if I have to.

So frustrating.


#5

Remember that here at Dreamhost, we can have multiple unix logins - e.g. lensman. Each of these logins has a different home directory - e.g. /home/lensman. Only one of these home directories contains the “real” web directory for domain.

If you “edit” hosting for the domain, it will show both the user and the web directory for the domain.

From your explanation, it’s pretty clear that you happen to have two different directories named wretchawry.com. You’ve put your files in the wrong one. If it’s not too much trouble, you should re-upload all the files to the correct one - the one that’s empty now. As an alternative, you can edit the hosting for wretchawry.com and change the FTP user / CGI-runs-as user to your “other” login. It all depends on which user you want the files under.

Does this make sense?

BTW, if you don’t want to re-upload the files, you should be able to copy all the files over by using

cp -R /home/originalusername/wretchawry.com /home/otherusername/wretchawry.comat the command line. You’ll have to enable your second unix login for shell access, download an SSH client like PuTTY, login, then issue the cp command as above.

Use the [color=#CC0000]3DOM50[/color] promo code for 3 extra lifetime domains and $50 off
More Dreamhost coupons here!


#6

But I don’t understand why I’m not seeing this empty directory in my WS-FTP. I see the other domain I moved to DreamHost a couple of years ago. I do all my uploading via WS-FTP, constant updating and tweaking. If I can’t find the directory I’m just as up the creek.


#7

It all has to do with which username you’re using to log in as. Maybe without knowing it, you’ve set up two separate users with two separate home directories - wretchawry and equipoise. You’ve set the web directory for wretchawry.com to /home/wretchawry/wretchawry.com and then you uploaded all your files to /home/equipoise/wretchawry.com.

Does that make sense?

Use the [color=#CC0000]3DOM50[/color] promo code for 3 extra lifetime domains and $50 off
More Dreamhost coupons here!


#8

Ok, I went into the Support History folder and found a message telling me that…

“The purpose of this email is to let you know that your FTP account
’wretchawry’ has just been activated, and you can begin uploading any
files you wish to it (including those for your web site).”

I went to my WS-FTP and put in the information that was given me. And it worked! I can now see the 4 different domains, including the wretchawry.com with its empty directory.

I’m still confused though. The letter also said this:

“If you have a domain or sub-domain hosted under this account, you should
see a sub-directory within your home directory named after it. This is
the directory you’ll need to upload your files into if you want to see
them on the web (once your domain becomes active).”

And I should, because that’s what happened with the other domain I moved to DreamHost a couple of years ago. I didn’t have to create a new WS-FTP site. So, something is wrong on the DreamHost side. Something changed.

At least I found it. I just wish I had found it where it was supposed to be. I’ll try your tip for moving the files because I sure don’t want to upload everything all over again.


#9

Just for the heck of it I started uploading the files again via WS-FTP, and it’s uploading at the blazing fast speed of 38 KB/S and it will take a relatively short 31 hours to re-upload everything. (note sarcasm)

Damn.


#10

As pointed out, the web directories are stored in a the direcotry of a user on your account. Thus if you don’t log into FTP using the right username, you won’t be uploading the files to the right place.

Go back to the “Add A New Domain / Sub-domain” panel.

You will see that it asks you to choose an existing “FTP / CGI” user or to create a new user. Thus whatever selected here you must use for FTP.

Given the message in your support history, apparently you ended up with the DreamHost system thinking you wanted to create a new user named ‘wretchawry’ so it did. And it associated the domain with this new user instead of an existing user.

:cool: openvein.org -//- One-time [color=#6600CC]$50.00 discount[/color] on [color=#0000CC]DreamHost[/color] plans: Use ATROPOS7


#11

Thank you for the help patricktan, Lensman and Atropos 7! Everything’s working now. Atropos 7, you’re right, I think that’s what happened. Miscommunication. I moved over the earlier domain when DreamHost had phone support and the person at the other end did it for me, so that’s how the two after the original got put in with the origina “root” directory, instead of these 4, which got put into an entirely different place not accessible from my root.

I started a new WS-FTP session, and it was fine. It’s a bit weird to have 2 WS-FTP windows open (one to upload files to suspended-in-gaffa.com and the other to upload files to wretchawry.com and the other new ones) but it’s not a big deal.

Lensman, THANK YOU for the tip copying files from one directory to another. That saved me hours and hours and many hours. It worked like a charm and was fast!